summaryrefslogtreecommitdiff
path: root/dev-python/docutils-glep/docutils-glep-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-python/docutils-glep/docutils-glep-1.2.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-python/docutils-glep/docutils-glep-1.2.ebuild')
-rw-r--r--dev-python/docutils-glep/docutils-glep-1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/docutils-glep/docutils-glep-1.2.ebuild b/dev-python/docutils-glep/docutils-glep-1.2.ebuild
new file mode 100644
index 000000000000..cc7630dcaa83
--- /dev/null
+++ b/dev-python/docutils-glep/docutils-glep-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Gentoo GLEP support for docutils"
+HOMEPAGE="https://github.com/gentoo/docutils-glep/"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+S=${WORKDIR}/${MY_P}