summaryrefslogtreecommitdiff
path: root/dev-python/doit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
commit9b55c1bd600df28af7b9f6ee044b714873e19b49 (patch)
tree9c6d86e5e38b0aed45d07dc73907e9f818783a4d /dev-python/doit
parent61044571b76d87a2eec42d36c9b7addf3e66e000 (diff)
gentoo auto-resync : 26:02:2023 - 09:56:20
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.36.0-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index 3243a737840a..89be338f1f42 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,3 +1,4 @@
DIST doit-0.36.0.tar.gz 1448096 BLAKE2B 15558a39ccac031ddf3a429aa585bc6e1d49c2e7572df29979ca66d1025fa5d7a917f6cc5bcfd21f2749e4ed7e7885b0865ec67b6fa32817e1518d47da9ead97 SHA512 d4caa31701755c7f59213dde0f89fd3616c0c01b7f06245cbfd9f1a315d503e62f3556c3b86685cd0ebfcffcc9cae0987ca150f037aa7b3cd960439a1191be42
+EBUILD doit-0.36.0-r1.ebuild 1501 BLAKE2B c2e4086ae31308e2ad97a88ab783151c439203413b2574713c05a63f12c02f233f997f5c74a804314ae302239ce0316651e72fb44b906fb370ee5858b606213c SHA512 bd6c9269e4945441e65d0e8011af597c0439642f723c0775453e99712d38f3ea0ed065cdeba2eb2ec4ddb94064bd209549a7d5b8d483a4c22002e6d037ae6554
EBUILD doit-0.36.0.ebuild 1537 BLAKE2B cd68c7e7e47f205e37a62a8852e17f75b77db6ef49e1d9f4f8f5d815ff77dfba55ede7e6a70d39cf998f96b0b4f3e9f8747031641d0968f700d2f37e76e637b4 SHA512 c90d5d2ce66900b16377715f77bcbfc3270b8fd12c935a8b714451498ee450a14766fba7889bee8c68de80c201b4619ac50c322dd0182f7586fc0755df1c6b6f
MISC metadata.xml 568 BLAKE2B add52a6e7986bb88b9dc87d2f03c4ec3716ae7d5e2402556b7a3137b8267ca2cad0ae3324d628f3127afde36513414029c0f567a9683dd9b11b1a287ff5e3a7d SHA512 e772c9ccd8133fd73dcf04733facf60ef7c2f1559b83e5024faeea4d5fd7799c42a28be6c9b8676ea9b6d68969ca5be633320e8cb7dd8d1f0dca35e819eaebc7
diff --git a/dev-python/doit/doit-0.36.0-r1.ebuild b/dev-python/doit/doit-0.36.0-r1.ebuild
new file mode 100644
index 000000000000..21d211e22506
--- /dev/null
+++ b/dev-python/doit/doit-0.36.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="
+ https://pydoit.org/
+ https://github.com/pydoit/doit/
+ https://pypi.org/project/doit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_dep # #836164
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+ # Remove non-exist modules for doc generation (#832754)
+ sed \
+ -e '/sphinx_sitemap/d' \
+ -e '/sphinx_reredirects/d' \
+ -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}