summaryrefslogtreecommitdiff
path: root/dev-python/duecredit/duecredit-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/duecredit/duecredit-0.7.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/duecredit/duecredit-0.7.0.ebuild')
-rw-r--r--dev-python/duecredit/duecredit-0.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/duecredit/duecredit-0.7.0.ebuild b/dev-python/duecredit/duecredit-0.7.0.ebuild
new file mode 100644
index 000000000000..3dc5dd555627
--- /dev/null
+++ b/dev-python/duecredit/duecredit-0.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Publications (and donations) tracer"
+HOMEPAGE="https://github.com/duecredit/duecredit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"