summaryrefslogtreecommitdiff
path: root/dev-python/dugong
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dugong
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/Manifest7
-rw-r--r--dev-python/dugong/dugong-3.7.1.ebuild32
-rw-r--r--dev-python/dugong/dugong-3.7.2.ebuild32
-rw-r--r--dev-python/dugong/dugong-3.7.3.ebuild32
-rw-r--r--dev-python/dugong/metadata.xml12
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/dugong/Manifest b/dev-python/dugong/Manifest
new file mode 100644
index 000000000000..6425ce9ea929
--- /dev/null
+++ b/dev-python/dugong/Manifest
@@ -0,0 +1,7 @@
+DIST dugong-3.7.1.tar.bz2 194243 BLAKE2B a7514f4b515fcd519f5c11b834d44d16cd395d9eada659dd1913bd07a9a072e19f6737a3d702d9ef2a63160eb5452f146a4b04e744610b8f51c9403a648aef9b SHA512 85c276bba85d650bf0baa6257bf0872cb2da546a23d19e0c94cc15c95721a8d9f6392db0e64b38ab2e801803e3ab7908e6a931d18736d33c87138eca35b4f27c
+DIST dugong-3.7.2.tar.bz2 206730 BLAKE2B f362208db26582a1d3681900e99b2143c779d4da1dff9f1a5bc21a2a00fbd0e0c1abb045a60b6cc29d173c0980c42c19f33d091c3b6f300d0e2d85b180b12995 SHA512 00b6d349fa7c5b8a356d663381a39bc40dd42fe9c01a92003c58437f4c4acc31fdde880b743f2c1035016e6f1e1d0f9cf6608832332f3a4a8640bf868680bea6
+DIST dugong-3.7.3.tar.bz2 206720 BLAKE2B 41dd349336ae37dd290c88233a4a1eed283a774a072396a03b0b97fe3aaca95a4aa90b2951ebc3d59c517221b1b1b77f90d64538f5a17fcc84fa927650af1fdb SHA512 b20b720fa18789ff137524b67dd7339ec3ad532cff164c03c74d38accc72e035d33ebe97df028f75d7d904f3d0d460f99edf7cf45abf9c4849a5a3a05529a7a4
+EBUILD dugong-3.7.1.ebuild 778 BLAKE2B 6009fb01fa66fd5cc61370abba8decddb266daa4cc3b46e3c462bad1ddee1e952a1e7a2465f8b83c543676e184019b113a4c9fed8d8ac2ac0d820ff876422d92 SHA512 be73a4ab89970d3fcfe2b651950eadab8ca3c7fc3652acdad632bb71874cb0faa3f673678c5f6f62a9175a5c73c391635ddadf2082371bc24b4429b09caeec73
+EBUILD dugong-3.7.2.ebuild 780 BLAKE2B 2a3ebb5e5d3d62cb96572e9d8c724158ac9ee282d6202bb81fcb1b32bafbcfdfc7aac28d0a03919a16e20b94e7d30f30b4bdd863bdef950bd5014f52716b165b SHA512 f0c8c62d4e17765bfb6c06a76d6be24b44e9e58c81cf7e222cd76899801f29277013cd81d0f3fec24a92408c3e2e3a3372e021d8ae0256aab704fd2ba07d71b5
+EBUILD dugong-3.7.3.ebuild 780 BLAKE2B 2a3ebb5e5d3d62cb96572e9d8c724158ac9ee282d6202bb81fcb1b32bafbcfdfc7aac28d0a03919a16e20b94e7d30f30b4bdd863bdef950bd5014f52716b165b SHA512 f0c8c62d4e17765bfb6c06a76d6be24b44e9e58c81cf7e222cd76899801f29277013cd81d0f3fec24a92408c3e2e3a3372e021d8ae0256aab704fd2ba07d71b5
+MISC metadata.xml 386 BLAKE2B 8a2dc259255a5fe345b1f1e04b1708bc34f7c31351b01b90a856b93604fef92be88bc75f7120dac1fb4f86f9aace962729a2d91e13094e5ee59b9c464280628f SHA512 9ac2081eb11077d2d9d7318410053fca1855abc8fe288bc18de829c1874e38c649620c56e2a7eb9fe29e41bed8dcb7c3327a2203c60511ab233a58d93f542db2
diff --git a/dev-python/dugong/dugong-3.7.1.ebuild b/dev-python/dugong/dugong-3.7.1.ebuild
new file mode 100644
index 000000000000..c6e321e5236d
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dugong/dugong-3.7.2.ebuild b/dev-python/dugong/dugong-3.7.2.ebuild
new file mode 100644
index 000000000000..e1144b98f8bd
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dugong/dugong-3.7.3.ebuild b/dev-python/dugong/dugong-3.7.3.ebuild
new file mode 100644
index 000000000000..e1144b98f8bd
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dugong/metadata.xml b/dev-python/dugong/metadata.xml
new file mode 100644
index 000000000000..2ae422c40102
--- /dev/null
+++ b/dev-python/dugong/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dugong</remote-id>
+ <remote-id type="bitbucket">nikratio/python-dugong</remote-id>
+ </upstream>
+</pkgmetadata>