summaryrefslogtreecommitdiff
path: root/dev-python/dulwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-python/dulwich
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest4
-rw-r--r--dev-python/dulwich/dulwich-0.20.35.ebuild58
-rw-r--r--dev-python/dulwich/metadata.xml4
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 8f419a876956..c4e084877adc 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,5 +1,7 @@
DIST dulwich-0.20.32.tar.gz 418100 BLAKE2B 21d41a7b1e491848a11ab3e3b1b63bfbe1798b38ef331136b07609f004e780672477e91a637dd3b1ccd3b26e359461e1a16d759ac2cb98d1091fbdb1968c00a9 SHA512 9af4cb4462ab9a69bea9074aace81eeb8d33087f2c53e64145991913ad132e076b62f7958551729c758cd6eeae029a278723872771ef36b046331c85ebf2fcf4
DIST dulwich-0.20.33.tar.gz 419863 BLAKE2B 57b7a05f7a23745ba63e2faba9cd3772637a61cf9f2077eaf7ec799f5e3d25de7245aabbebf22cb58f5cb45318b653335251fc46b136b108770aaa6c2b09e099 SHA512 f2d0f8875dc4cd4ac4629f2884a5e68938d14218ef96a19ce322559a16eb64cdee92ed0bc07790e9d527a20fdcd29f6fe1f95479d0055cdab88f509bc318368c
+DIST dulwich-0.20.35.tar.gz 420972 BLAKE2B 97c877554199aa8f3abf2f95a43c350cbef784f6f71af6280c537a93297c89981190fe1f66914532641a99cc3dca82a33b43d09f864f2ddf370c0097fa28a5e0 SHA512 23c272153547e0ef25a0e7d2deb64987e5d503545775e7d6f438ae09366c0037686eba1027d38a9dbf042bd1553eeb25ccdc818bdd785a2edf2cd3688f0b1271
EBUILD dulwich-0.20.32.ebuild 1618 BLAKE2B 7f39288d500bdfe1e2b7820d1482b3d336f9612dcc861e2d20a33ef7a0ed68a8790d6de3e7c6e19f6c4439fe2ee97d682d3b73c8e95d85f49b819df1cd80f8e6 SHA512 102f5b2a6d10f3c4e3b65b38678998138c17e491adbc5695353978229d0b5d776fe2d7409519861d176eb053e0d5c6f89ec86bb0e83904bb5151a17af2415497
EBUILD dulwich-0.20.33.ebuild 1622 BLAKE2B 5e4f668dd9ac9e4cc4ed0d2e2a96f55724e3838cfba36aa4729af95d6e8c9e40603accfab50df5b105b269756fdb15c46dee53a0d99d352c26b43a3deae5ca9f SHA512 f487b2e6e0ad1245b7cb85fa93d3274284ed9ce179c59eec89b60d72180b2c8129e0e11e80db342c08ff1e772116d2d64966d80bd64f97024a536ce995b63a35
-MISC metadata.xml 558 BLAKE2B 72c574d6eb1a3d94686fe9aeeb53fa8d96532f4477ee94bfcd6c0dd3e0d6fc9e313dba9642b68a57ba0b38830fbe1f8d953c3ae79bcafcb6bbf6eba0e35f61a1 SHA512 de70aed32ec0b362668a6fd33d8be5251d57048bd6396e09608f040fe71fe8e3262f1c96fbc8058ea776e09a59ac465652f4f7d778fb4e3933c7fea4bf64d7f4
+EBUILD dulwich-0.20.35.ebuild 1623 BLAKE2B d5896e0f00d7bb4e723abd1c6f2cd5aa5d997e62a406dd36990998fcd24d343a4597d672bac1e8112e86d95313b2dabb25be9dfdf2440f0ff0953594819a998e SHA512 8810c5488adf22a1bcf421f13890e1477884f1c23de3c900472cddf1d78b8763e6e75b0abf0321d0c5b13431b4261e9f9c87a54dacecdf29f6c92a55a1c8606f
+MISC metadata.xml 556 BLAKE2B 240554ff522160e9508bf6debadafcc44b5ccc4074dd4c9d3ce82358963084c60a1afae9fafee6ab1e6e5d898940ccb4d1b524cebff155e61bf6707c9396b647 SHA512 a7cdca224a01d5bd26bf4a5adb0273977ddff61f75cd02f5642132656fd0c6608114617efcb068d834f107804666cf4fb3725967e804b73d2ddcb67342dc30de
diff --git a/dev-python/dulwich/dulwich-0.20.35.ebuild b/dev-python/dulwich/dulwich-0.20.35.ebuild
new file mode 100644
index 000000000000..456dab9bb052
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.35.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) )
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/metadata.xml b/dev-python/dulwich/metadata.xml
index f558564f98b0..aaeecf0d1119 100644
--- a/dev-python/dulwich/metadata.xml
+++ b/dev-python/dulwich/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">dulwich</remote-id>
- <remote-id type="github">dulwich/dulwich</remote-id>
- <bugs-to>https://github.com/dulwich/dulwich/issues</bugs-to>
+ <remote-id type="github">jelmer/dulwich</remote-id>
+ <bugs-to>https://github.com/jelmer/dulwich/issues</bugs-to>
</upstream>
</pkgmetadata>