summaryrefslogtreecommitdiff
path: root/dev-python/dynd-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/dynd-python
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/dynd-python')
-rw-r--r--dev-python/dynd-python/Manifest3
-rw-r--r--dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild59
-rw-r--r--dev-python/dynd-python/metadata.xml15
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
deleted file mode 100644
index 11442569135a..000000000000
--- a/dev-python/dynd-python/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST dynd-python-0.7.2.tar.gz 184981 BLAKE2B 826a46c7c920533dbd64f310ce6136e37f5d3f7e2bb1190977c72e9c7b65aa9957547b02ca92f5aadc1db268ca4ceda9459036e9fe24a57e090f4312645d348b SHA512 e51df7b368b1f6869338cb12a2f093064b1e7531ef674a83dbc7b9cc1dc6143cbe12cb37273bcc01e7b1066eda541b3b15473bc01e88fd9a8d1b594f6f37eaba
-EBUILD dynd-python-0.7.2-r2.ebuild 1550 BLAKE2B 274325ade3778ef1107bba3320248b9358a71eff03493ce134211fb2dc869b33242bc25396fc88de37e9c57db43926fb3927271895df5419d78e6c823706f2da SHA512 ff672fece6a1cc4ae469f46bdc7f9b66a0461317dc90e1e5bdd3d79a9aff8661aeaa3de59fb97f8934d09ab033f21468447bcf7ba4969a4464627e20ac967bf5
-MISC metadata.xml 529 BLAKE2B bc365c7019af30defbcddf4eb0c590666199d43acba144d4b42f21fecea7c572d6122b60bd0b767437ec4b1887e7d3bc50c50b83f88deb99e627cb67030ec95f SHA512 8500904a91a51d552ef6f0fe17486b8d935bc4f50860120376ed40a31c002bda8ca66b5c3c8b8c244dccf659cbf8574f1e031e62a0a0b870af133062055a25b9
diff --git a/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild b/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild
deleted file mode 100644
index 7fe6afddb277..000000000000
--- a/dev-python/dynd-python/dynd-python-0.7.2-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-# change each new dynd version, to avoid git in tree dependency
-DYND_PYTHON_GIT_SHA1=8cdef57e71c784d7fe1f3f97a2ce2ce5727a89f1
-
-DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
-HOMEPAGE="http://libdynd.org/"
-SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- ~dev-libs/libdynd-${PV}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- # remove the version mangling from git stuff it requires a git clone
- # rather force set it a configure time
- sed -e "/--dirty/s/ver =.*/ver = 'v${PV}'/" \
- -e '/--always/d' \
- -i setup.py || die
- sed -e "s/get_git.*/set(DYND_PYTHON_GIT_SHA1 ${DYND_PYTHON_GIT_SHA1})/" \
- -e "s/git_describe.*/set(DYND_PYTHON_VERSION_STRING v${PV})/" \
- -e 's|-g -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- -i CMakeLists.txt || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- cd "${BUILD_DIR}/lib" || die
- PYTHONPATH=${BUILD_DIR}/lib nosetests -v || die
-}
diff --git a/dev-python/dynd-python/metadata.xml b/dev-python/dynd-python/metadata.xml
deleted file mode 100644
index 67e99838f6fd..000000000000
--- a/dev-python/dynd-python/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- DyND-Python, a component of the Blaze project, is the Python
- exposure of the DyND dynamic multi-dimensional array library.
- </longdescription>
- <upstream>
- <remote-id type="github">libdynd/dynd-python</remote-id>
- </upstream>
-</pkgmetadata>