summaryrefslogtreecommitdiff
path: root/dev-python/dynd-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/dynd-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/dynd-python')
-rw-r--r--dev-python/dynd-python/Manifest3
-rw-r--r--dev-python/dynd-python/dynd-python-0.7.2-r1.ebuild59
-rw-r--r--dev-python/dynd-python/metadata.xml15
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
new file mode 100644
index 000000000000..12ecddd7dda8
--- /dev/null
+++ b/dev-python/dynd-python/Manifest
@@ -0,0 +1,3 @@
+DIST dynd-python-0.7.2.tar.gz 184981 BLAKE2B 826a46c7c920533dbd64f310ce6136e37f5d3f7e2bb1190977c72e9c7b65aa9957547b02ca92f5aadc1db268ca4ceda9459036e9fe24a57e090f4312645d348b SHA512 e51df7b368b1f6869338cb12a2f093064b1e7531ef674a83dbc7b9cc1dc6143cbe12cb37273bcc01e7b1066eda541b3b15473bc01e88fd9a8d1b594f6f37eaba
+EBUILD dynd-python-0.7.2-r1.ebuild 1543 BLAKE2B c0200371b78ca09a9437f57a05867983fb17e8014be0fe3222bf5e9371555b7d74d33f443f81bd34183bf27bfabb4b8ec69bdf14972d9a2955401b02f07ddf5e SHA512 86ed7448a9e1e56d5e1c9e6c9c0a1eaefd42cbe0fcb8690293335cbb5dc9ac43901c62e320eb20bacc360d4d59970feffb1b846cc6996cc79b1ab0b9b5354ed6
+MISC metadata.xml 529 BLAKE2B bc365c7019af30defbcddf4eb0c590666199d43acba144d4b42f21fecea7c572d6122b60bd0b767437ec4b1887e7d3bc50c50b83f88deb99e627cb67030ec95f SHA512 8500904a91a51d552ef6f0fe17486b8d935bc4f50860120376ed40a31c002bda8ca66b5c3c8b8c244dccf659cbf8574f1e031e62a0a0b870af133062055a25b9
diff --git a/dev-python/dynd-python/dynd-python-0.7.2-r1.ebuild b/dev-python/dynd-python/dynd-python-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..458dea2c37c7
--- /dev/null
+++ b/dev-python/dynd-python/dynd-python-0.7.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+# change each new dynd version, to avoid git in tree dependency
+DYND_PYTHON_GIT_SHA1=8cdef57e71c784d7fe1f3f97a2ce2ce5727a89f1
+
+DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
+HOMEPAGE="http://libdynd.org/"
+SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/libdynd-${PV}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # remove the version mangling from git stuff it requires a git clone
+ # rather force set it a configure time
+ sed -e "/--dirty/s/ver =.*/ver = 'v${PV}'/" \
+ -e '/--always/d' \
+ -i setup.py || die
+ sed -e "s/get_git.*/set(DYND_PYTHON_GIT_SHA1 ${DYND_PYTHON_GIT_SHA1})/" \
+ -e "s/git_describe.*/set(DYND_PYTHON_VERSION_STRING v${PV})/" \
+ -e 's|-g -fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ -i CMakeLists.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ PYTHONPATH=${BUILD_DIR}/lib nosetests -v || die
+}
diff --git a/dev-python/dynd-python/metadata.xml b/dev-python/dynd-python/metadata.xml
new file mode 100644
index 000000000000..67e99838f6fd
--- /dev/null
+++ b/dev-python/dynd-python/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ DyND-Python, a component of the Blaze project, is the Python
+ exposure of the DyND dynamic multi-dimensional array library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">libdynd/dynd-python</remote-id>
+ </upstream>
+</pkgmetadata>