summaryrefslogtreecommitdiff
path: root/dev-python/emoji/emoji-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
commit9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (patch)
tree4ac39398cd519351bf12c6357e7474c508f19d13 /dev-python/emoji/emoji-2.0.0.ebuild
parentb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (diff)
gentoo auto-resync : 17:07:2022 - 14:31:38
Diffstat (limited to 'dev-python/emoji/emoji-2.0.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.0.0.ebuild b/dev-python/emoji/emoji-2.0.0.ebuild
new file mode 100644
index 000000000000..20469a0482c6
--- /dev/null
+++ b/dev-python/emoji/emoji-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest