summaryrefslogtreecommitdiff
path: root/dev-python/enaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-python/enaml
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-python/enaml')
-rw-r--r--dev-python/enaml/Manifest2
-rw-r--r--dev-python/enaml/enaml-0.10.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/enaml/Manifest b/dev-python/enaml/Manifest
index 7f73babc9ca7..0f919e456830 100644
--- a/dev-python/enaml/Manifest
+++ b/dev-python/enaml/Manifest
@@ -1,3 +1,5 @@
+DIST enaml-0.10.2.tar.gz 1568147 BLAKE2B 627e34f0703a54a7298c405406c2d96eb29f0d278c535f9e0a49d981dc8c4264a935fe34e97e4a1cfbcf4f4f1b9c24e00596bd850bdc87a29ef4429f9d620dce SHA512 fb78d5202fb595d28aae92455a70d4e6057c8a5daf05b4487f6e3aca38b7e495684ef6ccd4ce5bdd04e53be7231e6d39db73341005c12922d69ccfde38b84957
DIST enaml-0.9.8.tar.gz 1455642 BLAKE2B f17b5a4a531b231babc44ea9c81d607989fe0a80a4c2b1c9ea7c0ef880388523b72b5e276d7815196b515052cefce78f3d29b08c67c181ffd080557d87098e30 SHA512 e9b88d1fbb9e82564d3a865f74685b1b1f8b8918e29dd4d7ce7d6b4b2e6d386c6388e99f9bf0adb02fb9277a57519f8502a33bd6e0548fd1a4d52d0a4b33cf02
+EBUILD enaml-0.10.2.ebuild 1523 BLAKE2B 504a3381db23dacce4b9b7e64042a3b793a5270d0fb383e31daa8cbc3bb043cf81c35028aad22a185049dc034604648dadebcc61703ff72dc22d6e0db78731dd SHA512 c757ae675acac4b20d07369f6f229796bd62acde3a3b85b956a3bd0edb5e98e837a1aeae81046012bcc6b09bc09f012112efe58a85a27622d174893f60d039af
EBUILD enaml-0.9.8.ebuild 1671 BLAKE2B 39da0c281b6e09bf9cd012b3d98f3e0b293d672c9edf9f0f1da5ceddc5dba15cbc8bcb8480bb78261841c57628d9782c7623053082f3a7f6a832ce597862dac1 SHA512 bab220c729adb94b406d6626653f06daec88e7938b2470b2942d09c53e322029713e190553afea5faa26c2bef1c667fbcb9db3ded0ca2dc126a1adbadf5b3279
MISC metadata.xml 631 BLAKE2B c569dc2d11f6547b626497c18e70001cee289473eaae2c5bb7370a1df366b5860835371c416bbc2ddf4cb03b2b6edbc06ac7cb59acc2537fe52eb4ac501eed33 SHA512 2c642e89488173558b55516bfc7830c8e324f79508b133a4b238b85588f58417a8ed2edcea4dee94dea734e4e9d6adef873bffc12d53e4c6655a59bc7309b3b4
diff --git a/dev-python/enaml/enaml-0.10.2.ebuild b/dev-python/enaml/enaml-0.10.2.ebuild
new file mode 100644
index 000000000000..d634aaa9aa07
--- /dev/null
+++ b/dev-python/enaml/enaml-0.10.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1 flag-o-matic virtualx
+
+DESCRIPTION="Enthought Tool Suite: framework for writing declarative interfaces"
+HOMEPAGE="https://github.com/nucleic/enaml https://pypi.python.org/pypi/enaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/atom[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/kiwisolver[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ >=x11-libs/qscintilla-2.10.3
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+# The testsuite antagonises gentoo conventions far beyond what can currently be dealt with
+# It also passes all once run
+RESTRICT="test"
+
+# Doc build now fails, missing required folder, use doc removed for now
+# https://github.com/nucleic/enaml/issues/170
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt5
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}