summaryrefslogtreecommitdiff
path: root/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
commit4d9aef45678c7cb55b24107642790224ab8c153b (patch)
treeb1c56639785aeba23901272429a46e4e872a7711 /dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
parentf09a6cf772eb2f757f0fc49f3297d6a095a10aa5 (diff)
gentoo auto-resync : 19:08:2023 - 09:38:07
Diffstat (limited to 'dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild')
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
new file mode 100644
index 000000000000..8346a1bd0f6d
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-68.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}