summaryrefslogtreecommitdiff
path: root/dev-python/entrypoint2/entrypoint2-0.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/entrypoint2/entrypoint2-0.2.4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/entrypoint2/entrypoint2-0.2.4.ebuild')
-rw-r--r--dev-python/entrypoint2/entrypoint2-0.2.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/entrypoint2-0.2.4.ebuild b/dev-python/entrypoint2/entrypoint2-0.2.4.ebuild
new file mode 100644
index 000000000000..54283a5fbda0
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-0.2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest