summaryrefslogtreecommitdiff
path: root/dev-python/enum34
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/enum34
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/enum34')
-rw-r--r--dev-python/enum34/Manifest3
-rw-r--r--dev-python/enum34/enum34-1.1.6.ebuild29
-rw-r--r--dev-python/enum34/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/enum34/Manifest b/dev-python/enum34/Manifest
new file mode 100644
index 000000000000..889aa3ca31ee
--- /dev/null
+++ b/dev-python/enum34/Manifest
@@ -0,0 +1,3 @@
+DIST enum34-1.1.6.tar.gz 40048 BLAKE2B 3960e78f27f3ebf70e9aac5c4ced87d974cc61e5d9afe5d787188e3e877eece18153036035187e4d7ad63bf2a54c1c393f0f46f5ef7bcc9b67658b4ea441bb7b SHA512 51652525adc37bd1af1d81933f965dba9c508838d9f759c80ca1392991515a29c2c0263264a4e175b37a6ba11dca68c354774e448b19ef1bdba96be5474d93ec
+EBUILD enum34-1.1.6.ebuild 772 BLAKE2B 56fdffbd32ed69389e1e238863fd7906ee722c08741f4346079f23164e7264ad988fad03b8e14c7e342ac1559e5c924e2e9e44cf13316339d2fd0f6d8a6d94e9 SHA512 797e11f6b0aa20bd9fa8224814d985840ed3105ad87a42e688fae79e49b35a372360679939ba7672a10ef93f4e61e10e06c0cba7e27e7259ccd0c78c5c3bd327
+MISC metadata.xml 319 BLAKE2B 37b3564999c86bcff651225939b50aaba7aa54775af2bd02f23296204b49dcf8bc0434e48e05d820cda9c127983606ab1ecbec35a16dd7deebc9e32e3ed18422 SHA512 bca4e776e7253b8b88225336218101fe4ca88d41d0e597af7f0ca1129ee4916ee5a05dddc6ca1649b7cc3f62db654c9281b2616e807d6c178260296eebdc245e
diff --git a/dev-python/enum34/enum34-1.1.6.ebuild b/dev-python/enum34/enum34-1.1.6.ebuild
new file mode 100644
index 000000000000..e8abb317f929
--- /dev/null
+++ b/dev-python/enum34/enum34-1.1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3.4 Enum backported"
+HOMEPAGE="https://pypi.org/project/enum34/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" enum/test.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local DOCS=( enum/doc/. enum/README )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/enum34/metadata.xml b/dev-python/enum34/metadata.xml
new file mode 100644
index 000000000000..7f5caa77e9c1
--- /dev/null
+++ b/dev-python/enum34/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">enum34</remote-id>
+ </upstream>
+</pkgmetadata>