summaryrefslogtreecommitdiff
path: root/dev-python/eradicate/eradicate-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-02 07:28:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-02 07:28:45 +0000
commit4c91fc4c0d1da2829c584bd0517280eb4daf33d5 (patch)
tree0ae0ff890238f90dcc97bff617271214c48d2f1f /dev-python/eradicate/eradicate-2.2.0.ebuild
parent5711c6777e7610093a43849c3d874c52ac421b64 (diff)
gentoo auto-resync : 02:03:2023 - 07:28:45
Diffstat (limited to 'dev-python/eradicate/eradicate-2.2.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.2.0.ebuild b/dev-python/eradicate/eradicate-2.2.0.ebuild
new file mode 100644
index 000000000000..d77ad1099711
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="
+ https://github.com/myint/eradicate/
+ https://pypi.org/project/eradicate/
+"
+SRC_URI="
+ https://github.com/myint/eradicate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest