summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/exceptiongroup
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index f2951207e2f5..453ee6bbb2f8 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,5 @@
DIST exceptiongroup-1.2.1.tar.gz 28717 BLAKE2B 70e8093ad6af81343bf90e349671265e612f12fe25e5caeaef5917353159415215e4bb1921d9a0fcde6c3bd1a31a84f032827a2d5d8884daea777d7b110d8995 SHA512 7e0216ac2d76f0b3d29a0690790aa98d8e0f019eaee74e37e4ddcb97553a6a4d5037982478e663e8dfba49731444decda06122a3cb68f1c538589f5b43bdebfc
+DIST exceptiongroup-1.2.2.tar.gz 28883 BLAKE2B 713a1dcce6575eb8513fc5016b5ef5c11cafeb910f96ab556916da4c109be228cabc078551244d04acb9521ae7af65e1d93a02d7f40fa985760421138f7ccb73 SHA512 dedee1401577d1047a99078552cf24346c55f1e9a281845f327d8ace30b22659877743ce1c8b60fa605988abcac14432138020e9d1c109df911f86993cbe2082
EBUILD exceptiongroup-1.2.1.ebuild 789 BLAKE2B 82351661933a4cdc062d7995d52e0ffedbaf88f53a98739290bad516742a81e01c820a6232320ec3aa00c031be6943b651084fc469714ed8066b6de90f8e9c43 SHA512 4ba2b394bb3ab3c0cc1549ca3cbe96d419354acf5a090546b249090bb73a8aa2c0d9bafed84d23eeca5426752f19fa8415c9ac1f14e66dbb4513a7f9346c320e
+EBUILD exceptiongroup-1.2.2.ebuild 605 BLAKE2B fe5627d26f0877b715a3b150f7caf722f14dcada2e7103a395ba33da1d98ca152a03f689fc99a5aad04feeb64c3de1a7dbe3795ce4c7b8dd7a578c4011afa253 SHA512 f16928e56621d752718335c2c3c230ed248c3d8f98ed5fe9c92e7f9a95052d0673d4febe683978433abe272117282a22be1683b21714a9a615acf06f810c0274
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.2.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.2.ebuild
new file mode 100644
index 000000000000..90abf7cf4769
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}