summaryrefslogtreecommitdiff
path: root/dev-python/exdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/exdown
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/exdown')
-rw-r--r--dev-python/exdown/Manifest3
-rw-r--r--dev-python/exdown/exdown-0.7.0.ebuild41
-rw-r--r--dev-python/exdown/metadata.xml16
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/exdown/Manifest b/dev-python/exdown/Manifest
new file mode 100644
index 000000000000..911c07d39afa
--- /dev/null
+++ b/dev-python/exdown/Manifest
@@ -0,0 +1,3 @@
+DIST exdown-0.7.0.tar.gz 4592 BLAKE2B 00d53d19a44775a486b2f2133dfc7956e0dc724397e4c2729ab20123aea4841b4f450d28d89b5ee93a540b775099e70d1eb4a9917bec88be784d916518b06c0d SHA512 25c99e219d722ba1280119b7affd4bc83aa2e3b83ad60f74a7dca24c0f64a14acd3d4a0b116474cc4a3d3e4507c7b1300d9afecc14d2e3f400a5d4234334c5ee
+EBUILD exdown-0.7.0.ebuild 952 BLAKE2B 0f696fd01e8307bef9da0962b93e9f65ea4512b8a61c0b0feb0d14b23635ed51331733bfdb5d243b4c72a5a1c82f5f567473a6fbea460898504648740bb44c40 SHA512 26b511a610da0f6ae791496aa2f5f62da209953905ed7a589aaa1af88cd3381dc9264d78df2682e453812fd29ce66828f0dba1bb2c90f7fa2892ceb6af9a0e07
+MISC metadata.xml 498 BLAKE2B 1e328e87490d3e8c0eb1e34e83ef44dcf557851459015d87433fd892b012dbe805952e0f0fdefa68004f2024c7dc0a957de53e1458fa496a5bceaaab907da2c8 SHA512 52f4040fc042bf37b4f8d4d802d021bfb85ed2f510c1dea8dd1d2aa33674eebe6c5c4d24110609d200ef4b59529dd7ac1be30d2442381b6b36f5d3f11445026d
diff --git a/dev-python/exdown/exdown-0.7.0.ebuild b/dev-python/exdown/exdown-0.7.0.ebuild
new file mode 100644
index 000000000000..6121e9c8720e
--- /dev/null
+++ b/dev-python/exdown/exdown-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/exdown"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $( python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # setup.py was removed in commit ddb8a613bbc8ba7d079c1b7abbca5ce2d53ef9d0
+ # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
+ # it complains about file not found, setup.cfg does exist
+ cat > setup.py <<EOF || die
+from setuptools import setup
+
+if __name__ == "__main__":
+ setup()
+EOF
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/exdown/metadata.xml b/dev-python/exdown/metadata.xml
new file mode 100644
index 000000000000..99d8fdee9cb0
--- /dev/null
+++ b/dev-python/exdown/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nschloe/exdown</remote-id>
+ <remote-id type="pypi">exdown</remote-id>
+ </upstream>
+</pkgmetadata>