summaryrefslogtreecommitdiff
path: root/dev-python/execnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/execnet
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest3
-rw-r--r--dev-python/execnet/execnet-1.7.1.ebuild44
-rw-r--r--dev-python/execnet/files/execnet-1.7.1-tests.patch224
3 files changed, 271 insertions, 0 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index cebae04823ad..4dca4f8df753 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,5 +1,8 @@
+AUX execnet-1.7.1-tests.patch 7299 BLAKE2B a2bf00a2b283dcebb777ff4743f6dbd522ddb8ede743f77bbaa20b1b2e5956ea08e04359459a2c6837a5b2bb64585b8bf3bb826236acbbd874ffa5950d8d1196 SHA512 938bdc6185a5251a7f1e5185a694774a1b6e1c1ad39dbc444ee248f338f2e8a15dc3761980224f9eb378fa4c384a2c83f96f8a3ce55da2a24ea04b85997bdcf9
DIST execnet-1.4.1.tar.gz 171041 BLAKE2B 7e51320969b0203a8ff55d69364c3fa69d747d67f5dd3a3aaeab7700192d63918bbc11ae29a1e26e466078f1ca87ea00ddcfe0f98132921bacfc95671c3ad7c7 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790
DIST execnet-1.5.0.tar.gz 168497 BLAKE2B 1777f3a72cbf75e5bdef90cdda956a5d8101980f299a1bade6d6faeec52e1026a18a87c8b6b08c8d27073acedacd38473f68c6823908701816b4725edd3d9fb0 SHA512 ca2b571fafdf8f68b3cc7a04ee326e3255828d4cde28ead65d0cef325569c3a6dee09359e525152248038de65326ffc6b75c8362f53aa5c0b3f736eb596cb2d9
+DIST execnet-1.7.1.tar.gz 174157 BLAKE2B 0c2f7b8918bdd5a3cd1fdc49607e571874e20bd26a4806a6ec1a11359b912ed09244afb781670ff24fbee752516d59ab2bba7f662bbcddb802e7e6efd2c544ef SHA512 375748c03f8d955bd8fca90d5c6308073c31a978fd7a604257512e0a710f899dec5db8a91d5bb5f16de9b0656e1742da9ab513827a1a065a5125bafcf1e63a70
EBUILD execnet-1.4.1.ebuild 1257 BLAKE2B f9fa662316ad31d0614a43c0cfea7c1112953d18d2047fc28093a4caba5248a17bb95ff014aa7303b2809c3a7db661ef499f08bea52e31066a0de48f622af22a SHA512 b517b123696eb9c6342b8b3cd5bf488cdf26eeb33b3d6e7a9e1496736d79a468c779cbce5c0a7fdb1ba12ef55533ac65257143eedad1001eb7332c7e7044aeff
EBUILD execnet-1.5.0.ebuild 1270 BLAKE2B b4140a099a54a731a5bd207eb3fbf376b837791b53846d5ded8fdf086f21379217e76a35b85c311e6767f3f26b99466733b46ff62a66fd32cae5fec9cca6ae52 SHA512 e74bf61737cea6d78fb64339aec858425f18878f8e4210f7ec6603f0490fa6e36eddcb6f1e49bf999c6e92129d53cc19a84a07258cbf6e45e7a9cb9a01e4ebfa
+EBUILD execnet-1.7.1.ebuild 1181 BLAKE2B 2980e46a6cfecd73056614e462ad38e314653d952e5ba1e622d246a5a3b2da1a495d038ed9c7d6fb73469e6da20b8bf2308883405b6013e600be58c201d52a7e SHA512 59109e7e7829fcda3d0c207353f126f660e47ccd4bf86687e0d875d5b574dd957a281d0721a1b3780e91c9d84ae273fa66d1d270d2634f299a55b500cdb2cc61
MISC metadata.xml 541 BLAKE2B a1e9f563cf102eef9dcde4800cca44d354e4cb7d77c20422074296c3eb2df1baa46f4cf5a803b07f454e98f902124f185ff24224f499d50577a2c2ed3cdbe21b SHA512 8afb04a008ce5704560a8f984dc5662abb01244b93bbf655bf0c66365a125a07dd1adca26f75df2bc89f923409b3687bc610f0ed739879a6f66167b799963091
diff --git a/dev-python/execnet/execnet-1.7.1.ebuild b/dev-python/execnet/execnet-1.7.1.ebuild
new file mode 100644
index 000000000000..fc19260a71da
--- /dev/null
+++ b/dev-python/execnet/execnet-1.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.org/project/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/execnet-1.7.1-tests.patch"
+)
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.rst || die
+
+ sed -i -r 's:(,[[:space:]]*|)"eventlet":: ; s:(,[[:space:]]*|)"gevent"(,|)::' \
+ testing/conftest.py || die
+
+ # get rid of setuptools_scm dep
+ sed -i -r "s:use_scm_version=.+,:version='${PV}',: ; s:\"setuptools_scm\"::" \
+ setup.py || die
+
+ printf -- '__version__ = "%s"\nversion = "%s"\n' "${PV}" "${PV}" > \
+ execnet/_version.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/execnet/files/execnet-1.7.1-tests.patch b/dev-python/execnet/files/execnet-1.7.1-tests.patch
new file mode 100644
index 000000000000..5144201d2a1f
--- /dev/null
+++ b/dev-python/execnet/files/execnet-1.7.1-tests.patch
@@ -0,0 +1,224 @@
+diff --git a/testing/test_channel.py b/testing/test_channel.py
+index 017abb0..0983bae 100644
+--- a/testing/test_channel.py
++++ b/testing/test_channel.py
+@@ -3,6 +3,7 @@
+ mostly functional tests of gateways.
+ """
+ import time
++import platform
+
+ import py
+ import pytest
+@@ -362,6 +363,7 @@ class TestChannelFile:
+ s = f.read(5)
+ assert s == ""
+
++ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
+ def test_channel_file_readline_remote(self, gw):
+ channel = gw.remote_exec(
+ """
+@@ -382,7 +384,7 @@ class TestChannelFile:
+
+
+ class TestStringCoerce:
+- @pytest.mark.skipif('sys.version>="3.0"')
++ @pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_2to3(self, makegateway):
+ python = _find_version("3")
+ gw = makegateway("popen//python=%s" % python)
+@@ -410,7 +412,7 @@ class TestStringCoerce:
+ assert isinstance(res, str)
+ gw.exit()
+
+- @pytest.mark.skipif('sys.version<"3.0"')
++ @pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_3to2(self, makegateway):
+ python = _find_version("2")
+ gw = makegateway("popen//python=%s" % python)
+diff --git a/testing/test_gateway.py b/testing/test_gateway.py
+index fc1cf6a..b06a18d 100644
+--- a/testing/test_gateway.py
++++ b/testing/test_gateway.py
+@@ -5,6 +5,7 @@ mostly functional tests of gateways.
+ import os
+ import socket
+ import subprocess
++import platform
+ import sys
+ from textwrap import dedent
+
+@@ -153,6 +154,7 @@ class TestBasicGateway:
+
+ assert result is True
+
++ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
+ def test_remote_exec_module_with_traceback(self, gw, tmpdir, monkeypatch):
+ remotetest = tmpdir.join("remotetest.py")
+ remotetest.write(
+@@ -233,6 +235,7 @@ class TestBasicGateway:
+ assert result == 42
+
+ @needs_osdup
++ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
+ def test_confusion_from_os_write_stdout(self, gw):
+ channel = gw.remote_exec(
+ """
+@@ -250,6 +253,7 @@ class TestBasicGateway:
+ assert res == 42
+
+ @needs_osdup
++ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
+ def test_confusion_from_os_write_stderr(self, gw):
+ channel = gw.remote_exec(
+ """
+@@ -355,6 +359,7 @@ class TestPopenGateway:
+ )
+ py.test.raises(channel.RemoteError, channel.receive)
+
++ @pytest.mark.skip(reason="fails if bytecode writing is on")
+ def test_dont_write_bytecode(self, makegateway):
+ check_sys_dont_write_bytecode = """
+ import sys
+@@ -498,7 +503,7 @@ class TestTracing:
+
+
+ class TestStringCoerce:
+- @py.test.mark.skipif('sys.version>="3.0"')
++ @pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_2to3(self, makegateway):
+ python = _find_version("3")
+ gw = makegateway("popen//python=%s" % python)
+@@ -515,7 +520,7 @@ class TestStringCoerce:
+ assert isinstance(res, str)
+ gw.exit()
+
+- @py.test.mark.skipif('sys.version<"3.0"')
++ @pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_3to2(self, makegateway):
+ python = _find_version("2")
+ gw = makegateway("popen//python=%s" % python)
+diff --git a/testing/test_rsync.py b/testing/test_rsync.py
+index 995f229..a3f69a3 100644
+--- a/testing/test_rsync.py
++++ b/testing/test_rsync.py
+@@ -230,6 +230,7 @@ class TestRSync:
+ assert len(dest.listdir()) == 1
+ assert len(source.listdir()) == 1
+
++ @pytest.mark.skip(reason="tries to run other python impls")
+ @py.test.mark.skipif("sys.version_info >= (3,)")
+ def test_2_to_3_bridge_can_send_binary_files(self, tmpdir, makegateway):
+ python = _find_version("3")
+diff --git a/testing/test_serializer.py b/testing/test_serializer.py
+index 892e474..2f7f2f7 100644
+--- a/testing/test_serializer.py
++++ b/testing/test_serializer.py
+@@ -146,6 +146,7 @@ simple_tests = [
+ ]
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ @py.test.mark.parametrize(["tp_name", "repr"], simple_tests)
+ def test_simple(tp_name, repr, dump, load):
+ p = dump(repr)
+@@ -154,6 +155,7 @@ def test_simple(tp_name, repr, dump, load):
+ assert v == repr
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_set(py2, py3, dump):
+ p = dump("set((1, 2, 3))")
+ tp, v = py2.load(p)
+@@ -176,6 +178,7 @@ def test_set(py2, py3, dump):
+ assert v == "set()"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_frozenset(py2, py3, dump):
+ p = dump("frozenset((1, 2, 3))")
+ tp, v = py2.load(p)
+@@ -193,6 +196,7 @@ def test_frozenset(py2, py3, dump):
+ assert v == "frozenset()"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_long(py2, py3):
+ really_big = "9223372036854775807324234"
+ p = py2.dump(really_big)
+@@ -211,6 +215,7 @@ def test_long(py2, py3):
+ assert v == really_big + "L"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_small_long(py2, py3):
+ p = py2.dump("123L")
+ tp, s = py2.load(p)
+@@ -219,6 +224,7 @@ def test_small_long(py2, py3):
+ assert s == "123"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_bytes(py2, py3):
+ p = py3.dump("b'hi'")
+ tp, v = py2.load(p)
+@@ -229,6 +235,7 @@ def test_bytes(py2, py3):
+ assert v == "b'hi'"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_str(py2, py3):
+ p = py2.dump("'xyz'")
+ tp, s = py2.load(p)
+@@ -242,6 +249,7 @@ def test_str(py2, py3):
+ assert tp == "bytes"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_unicode(py2, py3):
+ p = py2.dump("u'hi'")
+ tp, s = py2.load(p)
+@@ -260,6 +268,7 @@ def test_unicode(py2, py3):
+ assert s == "u'hi'"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_bool(py2, py3):
+ p = py2.dump("True")
+ tp, s = py2.load(p)
+@@ -273,12 +282,14 @@ def test_bool(py2, py3):
+ assert s == "False"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_none(dump, load):
+ p = dump("None")
+ tp, s = load(p)
+ assert s == "None"
+
+
++@pytest.mark.skip(reason="trying to run stuff under different impls")
+ def test_tuple_nested_with_empty_in_between(py2):
+ p = py2.dump("(1, (), 3)")
+ tp, s = py2.load(p)
+diff --git a/testing/test_threadpool.py b/testing/test_threadpool.py
+index d469436..a473e4a 100644
+--- a/testing/test_threadpool.py
++++ b/testing/test_threadpool.py
+@@ -3,6 +3,7 @@ from __future__ import with_statement
+
+ import os
+ import sys
++import platform
+
+ import py
+ import pytest
+@@ -29,7 +30,7 @@ def test_simple(pool):
+ reply = pool.spawn(lambda: 42)
+ assert reply.get() == 42
+
+-
++@pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
+ def test_some(pool, execmodel):
+ q = execmodel.queue.Queue()
+ num = 4