summaryrefslogtreecommitdiff
path: root/dev-python/executing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/executing
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest4
-rw-r--r--dev-python/executing/executing-0.8.2.ebuild1
-rw-r--r--dev-python/executing/executing-0.8.3.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 5bdc01b7f75c..680c75f1f2db 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,3 +1,5 @@
DIST executing-0.8.2.gh.tar.gz 494836 BLAKE2B d6ade5658c8df656e80bb596f6c19493475d74ea10ddfc60b25eadb4a2f68d8afd2f437a6f82807932bba0469617fdac7a4dd90569623d1c8d7f96220e02ec9a SHA512 9a7fe4d3bae77d49725f35bae9d239bfb2a6e89d893d871d76f26fe4beffe0a07c6cbf50ea7b35b9ced66148d015c48106bc5774b26f201f9b40577f3380f5b3
-EBUILD executing-0.8.2.ebuild 946 BLAKE2B 949b516955b853367696363355def026a0d6f7f9f0016f66156ae25c310c1a7b7b5a62b30f808dbc2b520f4f4b9adb7aece184564e8f17d8845da8bfafb89838 SHA512 ece93dbe25a99f7edfb112485e5c9b29666b0c7a8bfb8951b8f3b3c0f2f74c4aa43471b70dd41bdd01017734697f9027b7e825175a5dab1d8fef5d1fde976267
+DIST executing-0.8.3.gh.tar.gz 495111 BLAKE2B ccb1a7df974f94b48960fc84a8365f6e57a7f34590972192e692f03340662e2bde97498c2ebf5617e45d8dfb6e866fd7de290644adb58e5338b2e0fdccc215f1 SHA512 4e01c1f48734c9568412b84160150e7e50ebdf5ba3dd466cf9d37b7f875ca2993915db75e2f6dd8e75e60b7b952fb0146928a41dde100ad38384b9be2ed60522
+EBUILD executing-0.8.2.ebuild 911 BLAKE2B e1d01c76c0f7d8a1564fe5dbdbe55fc3a110b78807eb601706105570366b4dbac93564123e7df85f9388968242f88e4c8085c714033b852ad410f1392f568ad1 SHA512 21cf05d8d88093abe0b016ab91528980fbb9f8578d81452d7ec716a21dcb37d58050f117118943f5f776531333b31a2f81d4918795d8b5d0719051e04bff8969
+EBUILD executing-0.8.3.ebuild 991 BLAKE2B 0379511c87ee07324556d5e4b697c4dc528c268decf12dfe37937603072afff4a4a2ac5bdd759e63e9d4d3057ef81034dc07926ac954e205e4f4b7e18912fb61 SHA512 464a60e0664fd6acb15ded35abff1050284a7282a2837c87dc931ab8989bbdf679ff0437e2e27aeb1daf661678ce4e1f732f6d94ab64b0deba629e1ac43335bf
MISC metadata.xml 351 BLAKE2B 3e64042e3da09377bd27bcf09b9984eef77bbbc18e84f1e849571ff628cd15068fa680560cfc6c3650bf545e5869c6e3d6be0b4d2fc00f35c5fc58dcc3194eb1 SHA512 de199443767adf299da6c7d857c182071746b2ccf7b84015e9649675451ff336fdb7ac1df2d15951ae708ddf0529f2f1c9c19a2959f45c0dc30db1f341fb8d0f
diff --git a/dev-python/executing/executing-0.8.2.ebuild b/dev-python/executing/executing-0.8.2.ebuild
index ab13f9f81f06..0be0c496ccd9 100644
--- a/dev-python/executing/executing-0.8.2.ebuild
+++ b/dev-python/executing/executing-0.8.2.ebuild
@@ -21,7 +21,6 @@ KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86"
# asttokens is optional runtime dep
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
test? (
dev-python/asttokens[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/executing/executing-0.8.3.ebuild b/dev-python/executing/executing-0.8.3.ebuild
new file mode 100644
index 000000000000..9ac690c815ad
--- /dev/null
+++ b/dev-python/executing/executing-0.8.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}