summaryrefslogtreecommitdiff
path: root/dev-python/fabric/fabric-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/fabric/fabric-2.3.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/fabric/fabric-2.3.1.ebuild')
-rw-r--r--dev-python/fabric/fabric-2.3.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/fabric/fabric-2.3.1.ebuild b/dev-python/fabric/fabric-2.3.1.ebuild
index 8265a2381332..430bb1ca83dd 100644
--- a/dev-python/fabric/fabric-2.3.1.ebuild
+++ b/dev-python/fabric/fabric-2.3.1.ebuild
@@ -3,18 +3,20 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="A simple pythonic tool for remote execution and deployment"
-HOMEPAGE="https://www.fabfile.org https://pypi.org/project/Fabric/"
+HOMEPAGE="https://www.fabfile.org https://pypi.org/project/fabric/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc fab2"
+# Depends on pytest-relaxed which is not in tree
+RESTRICT="test"
RDEPEND="
!fab2? ( !dev-python/fabric:0 )
@@ -26,24 +28,21 @@ BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/alabaster[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
)"
-# Depends on pytest-relaxed which is broken
-RESTRICT="test"
-
python_compile() {
if use fab2; then
export PACKAGE_AS_FABRIC2=1
- ln -s fabric fabric2 || die
+ ln -s fabric fabric2 || die "symlink create failed"
fi
distutils-r1_python_compile
}
python_compile_all() {
if use doc; then
- sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+ sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html \
+ || die "building docs failed"
fi
}