summaryrefslogtreecommitdiff
path: root/dev-python/fakeredis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /dev-python/fakeredis
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-2.24.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 211e34d07960..99214159b37d 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,5 +1,7 @@
DIST fakeredis-2.23.5.tar.gz 132797 BLAKE2B 1314ad46b310d4c1661b86593057afb3d1e9d0e4412146c1b883a17802c681e68062cb89dd89bc7cf3dfaac1eaf713fad7d4860986f50ed585a281208db0778a SHA512 e402cdd881872dc9af2e2b555d89329ba0eea0773f3924936774fc5a3a49d5fc9cba121f9bcddecc6d203f50bb2966aa7576496345966d415852ed8ed96cc8d4
DIST fakeredis-2.24.0.tar.gz 143594 BLAKE2B d14a163f9997b61bfcc156ffc47d5f18c94db9226e961c2bda7d4160d4c80e19db0a3c6a500511ad80f950e0c6ebd6ab160cf11cf6097ca3b26223183a54e889 SHA512 13a42750afd4f6432904aa01a841d7f3d2e8512955751fdf8f638b5e207039fa1b5e07bdcd28b7b9d1c1461a85a0c12cf7a1d663dd287220850575af097d2271
+DIST fakeredis-2.24.1.tar.gz 143606 BLAKE2B 1f89aed8f7a66c9100748946441d6a6876f1e0795337368fc34a9c89f1c256ddebcbd9b9597f4ff75703c78c3bc60031530423ce358dcc95c1567acec1b9856a SHA512 737ccfee02d05325e752d7cac8fb405937406acac9090709ead76ed8db2e1912f1c0d128a8ea354e78acfae317ec6bccb931f784720a3cd4c84693f9f3607a17
EBUILD fakeredis-2.23.5.ebuild 2348 BLAKE2B 8b9e67d78e802e8a104c54617b5ed514162e69e769b67fc1881fda27200248a19ca0846446a733e748a779787901a5b5f6a6390a87e2a2ae1c08b26b5346c8f8 SHA512 e356160b3a3dac3017b2df6a82558e8519776a1ea750b2d527602814a22758c0e782f84343b70f1830b9ee44d86df151e29a0a4c3d2a786a0adeaf7558e49cac
EBUILD fakeredis-2.24.0.ebuild 2564 BLAKE2B dd74879438e463fa78d75063227c910ab1446e50e1766562d9a8c711717f566c16f97d818bd882f453f3287b50947bc225d659bd5200b0c23af7b0ed94fbd13f SHA512 6fb0ac9ede7473793e5c341b9fd614412ef61b64d75da53e2a656e67d000d2d505b254b4b008687871172259acd00a74f440900f31042197054ec2c047f5830a
+EBUILD fakeredis-2.24.1.ebuild 2564 BLAKE2B dd74879438e463fa78d75063227c910ab1446e50e1766562d9a8c711717f566c16f97d818bd882f453f3287b50947bc225d659bd5200b0c23af7b0ed94fbd13f SHA512 6fb0ac9ede7473793e5c341b9fd614412ef61b64d75da53e2a656e67d000d2d505b254b4b008687871172259acd00a74f440900f31042197054ec2c047f5830a
MISC metadata.xml 373 BLAKE2B 1de33db59658e6190cd0346be58208cae6c9143a52f49dc289e68aaa0d860b5bd68dfb54f2e0b005f60a67f5caa430e2ce94fc69e64bd27e1bbebb07ad29e602 SHA512 24bfcf4919363fef45c182b6de66221e580ee0e9e99ce46e91b767655dc0b6f8a9fa6c3512ba84d1040698c43a0b6a853ad8d63c1ee5fbc00a1d192defb24db5
diff --git a/dev-python/fakeredis/fakeredis-2.24.1.ebuild b/dev-python/fakeredis/fakeredis-2.24.1.ebuild
new file mode 100644
index 000000000000..bc4af7542c89
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.24.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/cunla/fakeredis-py/issues/320
+ sed -i -e '/LICENSE/d' pyproject.toml || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6380
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}