summaryrefslogtreecommitdiff
path: root/dev-python/fastbencode/fastbencode-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
commit8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (patch)
treeece43c29d9163f887ef99c43aad6f2f568961231 /dev-python/fastbencode/fastbencode-0.3.1.ebuild
parent1b2360e7bab42e4045232887cb4f6c4a24ca3975 (diff)
gentoo auto-resync : 08:02:2025 - 00:11:30HEADmaster
Diffstat (limited to 'dev-python/fastbencode/fastbencode-0.3.1.ebuild')
-rw-r--r--dev-python/fastbencode/fastbencode-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastbencode/fastbencode-0.3.1.ebuild b/dev-python/fastbencode/fastbencode-0.3.1.ebuild
new file mode 100644
index 000000000000..050e3c30fde5
--- /dev/null
+++ b/dev-python/fastbencode/fastbencode-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Implementation of bencode with optional fast C extensions"
+HOMEPAGE="
+ https://github.com/breezy-team/fastbencode/
+ https://pypi.org/project/fastbencode/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest