summaryrefslogtreecommitdiff
path: root/dev-python/faulthandler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/faulthandler
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/faulthandler')
-rw-r--r--dev-python/faulthandler/Manifest7
-rw-r--r--dev-python/faulthandler/faulthandler-2.6.ebuild20
-rw-r--r--dev-python/faulthandler/faulthandler-3.0.ebuild20
-rw-r--r--dev-python/faulthandler/faulthandler-3.1.ebuild20
-rw-r--r--dev-python/faulthandler/metadata.xml12
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/faulthandler/Manifest b/dev-python/faulthandler/Manifest
new file mode 100644
index 000000000000..62c29b09bd2f
--- /dev/null
+++ b/dev-python/faulthandler/Manifest
@@ -0,0 +1,7 @@
+DIST faulthandler-2.6.tar.gz 54219 BLAKE2B 29f31974c2096990ce0954e9d4e72984980413235b2d4d078f0551434af4fe2e4d0d3cdbc8b80eb67bfdd89cc165350d73954902ff402c4debaf51a7609aea5c SHA512 884996a78b595c1c03c12d88687f5ee5051fabe162092a7b0c15a5ce51da33e64041bc1f2d4505bd5ae0d35a8e8d0e50dd08f603e58bdec5229f888ac46ce029
+DIST faulthandler-3.0.tar.gz 55577 BLAKE2B 8c4157393eb912d3f0e42ab6b942390a0ba2c068559ab8b66e6e3d961a2f7750f9cab000429feba46c0f9cc0a81ac2c8570d092ead1dcec8ea4e76e555cd1a8b SHA512 9e31682338e572e77e22a510637877c3e27440bc451854a898c5e58238d28a1bbf824cb2b44d1f1f11d8a4f491ddc299982a3d452eebec38bc2a03a824bac392
+DIST faulthandler-3.1.tar.gz 57961 BLAKE2B 1b0ed46cd98004cca56fa887a814e1bb02f6340e14f3c9a63769382583963829a829c60e4e2e153c4e7536cc37feaabf6841d019f6328a46388ff318c6d3e42b SHA512 fb133e7c1a8e2c611d9bcfa4d4b6ade92fb638ac60d12701d6bf5320f6a616e3e1b5f3b543f3e3c62f71e26167e2bdd17dfb4741bf758b7052286e5bc19faa59
+EBUILD faulthandler-2.6.ebuild 531 BLAKE2B bfeaef47af5b73fa2563789071265b0488a829050cb847a416281502bda71ba646c955dcd450183aa8451c17bb0f2495da92c534b4bfbe1f8335c1c8f6310875 SHA512 4fe411e55bff0ba78be32345ea7d59cb248b39e737a514a852a3698eec1ef6d0e832776cd337fb9e5219ca442940bc062948eee10c8f5f020c90919b2df522f9
+EBUILD faulthandler-3.0.ebuild 527 BLAKE2B 29a6b5a55d91da9398658bf97cecd37f5090821088a3cb42e3107c810f27ec0064fe80217cb0e5fb1da0ab074f463f3969291121cf3c7aab27dff582e11ee6be SHA512 318b460f24fbfe25dcaa2bc15c428e6eada66c10f5107e69690370619fe272b0eab0234e9c7832fb683817b2da188ecc929f04b158538dda8e388cda067d3666
+EBUILD faulthandler-3.1.ebuild 531 BLAKE2B 3a067161343e96c7a17227273135bcf6b677fddc46e7d1b3523ab5a484fd6f633d3975cba2bf03e9003b4195cbaceb8e119bbd4f55a1ba5712aba56892ff9cab SHA512 c577a67d0851c1292643f32488dadbee6ddbc58c1d9bbab8bbe0771aa557459462240f705aad00c6dc8322777ca6dffa5fc08c30b5dadd1defc3f45b0d710d17
+MISC metadata.xml 392 BLAKE2B e82a4c278ddfc0ea3f2b188de5ed0543b40f5b24b4a58faac722795c04892ecab77a98233de8ae347061ad4ddd2f87088969555862ba559e27838b9eea89e294 SHA512 1354c7b6391bfda781ad27395fdf230d81abb277452b7731caf870f356d1dc45a277130c9fa5bb61414f6160dd187622a261cf99be3bb53e5fb28b8cec4371dd
diff --git a/dev-python/faulthandler/faulthandler-2.6.ebuild b/dev-python/faulthandler/faulthandler-2.6.ebuild
new file mode 100644
index 000000000000..4288a90b9688
--- /dev/null
+++ b/dev-python/faulthandler/faulthandler-2.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="functions to dump Python tracebacks explicitly (on fault, user signal, timeout)"
+HOMEPAGE="https://github.com/haypo/faulthandler https://pypi.org/project/faulthandler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/faulthandler/faulthandler-3.0.ebuild b/dev-python/faulthandler/faulthandler-3.0.ebuild
new file mode 100644
index 000000000000..b469491e7ef0
--- /dev/null
+++ b/dev-python/faulthandler/faulthandler-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="functions to dump Python tracebacks explicitly (on fault, user signal, timeout)"
+HOMEPAGE="https://github.com/haypo/faulthandler https://pypi.org/project/faulthandler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/faulthandler/faulthandler-3.1.ebuild b/dev-python/faulthandler/faulthandler-3.1.ebuild
new file mode 100644
index 000000000000..67353df4507d
--- /dev/null
+++ b/dev-python/faulthandler/faulthandler-3.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="functions to dump Python tracebacks explicitly (on fault, user signal, timeout)"
+HOMEPAGE="https://github.com/haypo/faulthandler https://pypi.org/project/faulthandler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/faulthandler/metadata.xml b/dev-python/faulthandler/metadata.xml
new file mode 100644
index 000000000000..8583f2ad1028
--- /dev/null
+++ b/dev-python/faulthandler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haypo/faulthandler</remote-id>
+ <remote-id type="pypi">faulthandler</remote-id>
+ </upstream>
+</pkgmetadata>