summaryrefslogtreecommitdiff
path: root/dev-python/fedmsg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/fedmsg
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/fedmsg')
-rw-r--r--dev-python/fedmsg/Manifest6
-rw-r--r--dev-python/fedmsg/fedmsg-0.18.3.ebuild40
-rw-r--r--dev-python/fedmsg/files/0.18.0-endpoints.patch39
-rw-r--r--dev-python/fedmsg/files/0.18.0-no_signatures.patch29
-rw-r--r--dev-python/fedmsg/metadata.xml14
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/fedmsg/Manifest b/dev-python/fedmsg/Manifest
new file mode 100644
index 000000000000..65e6579c666a
--- /dev/null
+++ b/dev-python/fedmsg/Manifest
@@ -0,0 +1,6 @@
+AUX 0.18.0-endpoints.patch 1251 SHA256 f5c203b25669f4b24604bc34a462e527889618e3d70d0079fcfa9279be272291 SHA512 43a3850690980556e7a5ca8ae83359c7f9ef40d6556b590715ae40b5f1dd64c57ae4eef4898c935a556dd4230c53c75c246294ad30daa5a9c505c7ed3b1e39b6 WHIRLPOOL ae3b03e4ea001e6fc7cdb297b17dde03b6b6d9969b34ffcdc2ac2594af9e586600c3c920cc63da676d564d74d0ec8b260ca88f2bad44f95b24f014017a0a0329
+AUX 0.18.0-no_signatures.patch 820 SHA256 cc44833c81cc023498630807916af003bd157a510d66dd9594b055ce6ff73206 SHA512 d4869a6140b9594a6079257c55c86934f67c3eb69230881014501aac4c500efca2d20f1a2d3a69dc122444f63d14a42c87ba7eb3fd9468c8568d592378c6791b WHIRLPOOL 2852f81be49b859db64a29b5ee6bc628fde62f6392efd61b8b341f911f9cff415609485e6615fc85613175b349a6a83776b5b07f7f27c2147679bcc3d653a46d
+DIST fedmsg-0.18.3.tar.gz 540686 SHA256 1e870af77d9d27c83542849d24be3ee9807b1a36499e4471004e0473851ca0ac SHA512 59418b4da151c71962bf7d4d5c5005716c41578673b4786b0a6de3928b24e3de2976878fd66580f02848d453df4588d26d484d5eaf594ba7f49b1ba3a1cb2b00 WHIRLPOOL 8781fd2ed6db5a4308954d8ef063faa7a3545963cfffea62a1ec6e3237ae0a361944764c4f6a585a5e61699b70017a5d459a6d18d68b8b62e638b53d3a558762
+EBUILD fedmsg-0.18.3.ebuild 1042 SHA256 ba1eda7d86b9267d3be8250ecdc701f31ec2882aedf0a5865b2b0ece7ec05aa7 SHA512 e0d44c8d9f9b75ab01764c9b0ed78e3388926a1ccdb150beb4a5c1aa4f7c70377f10f4a4cf392b276f2da40d6e921e5fa40f6b41395b4b28ce0d8d628f0067f9 WHIRLPOOL 426eb04990fed70259fbd1845179100d519a24b8e53b5121c27cbf7a1edb24189ac66e7e4b21877718a9397af4570a902ebf7036356e1f9dc251d0882894211a
+MISC ChangeLog 1205 SHA256 bc53c812432cef4a8d4c47c3411d42d5c2df13ef777d1506b4cd942b3336915c SHA512 d82a6a8b48fc8dc0040c6a6a6934ef28be6857ab5e7503b8c8631703ffb612b2ec274b32e3cd7c914114e70ac01e224ddc7884acf45ef96963575ad7caf5a8b1 WHIRLPOOL 7a78a82d746094249a2374dfac50bec177bdd5a081e3316c9ee2a714bc50779b8af932cb2bf1904cf88a7c2b9a5e40962593ad0a3884df2bddb8f84c22cbe2ba
+MISC metadata.xml 393 SHA256 995f7f6416e6d3b24bf3271caae5e41e07b547d96a40820ea495f24db6dc6df6 SHA512 a26cb34971bbe8e273f3214ba98dee260a6175943d1c1cd2715b0ea7dfc9db1b18a615fa62617532ca0f6b2722992b6cb320b97339941a027bb58e2b6a458233 WHIRLPOOL 710b51e10affe41c638fb031fa9b0e963584478732ca2823d603ff563b8a42ee5cdabba6470f72226d8fa3bdedaf4f2969a61f25a007456699b8991cbdec71c2
diff --git a/dev-python/fedmsg/fedmsg-0.18.3.ebuild b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
new file mode 100644
index 000000000000..f59cd04664d7
--- /dev/null
+++ b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="Fedora Messaging Client API"
+HOMEPAGE="http://www.fedmsg.com/ https://pypi.python.org/pypi/fedmsg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/0.18.0-endpoints.patch"
+ "${FILESDIR}/0.18.0-no_signatures.patch" )
+RDEPEND="
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/m2crypto[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}"
+DOCS=(
+ "README.rst" "CHANGELOG.rst"
+ #TODO: doc/ dir full of rst files
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /etc/
+ doins -r "${S}/fedmsg.d"
+}
diff --git a/dev-python/fedmsg/files/0.18.0-endpoints.patch b/dev-python/fedmsg/files/0.18.0-endpoints.patch
new file mode 100644
index 000000000000..857f6839b5e3
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-endpoints.patch
@@ -0,0 +1,39 @@
+From 8bc5cbaa977b8de962f68ef84f6c8fadcb369c85 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:12:20 +1300
+Subject: [PATCH 1/2] Adjust endpoints to be more suited to gentoo users
+
+---
+ fedmsg.d/endpoints.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/fedmsg.d/endpoints.py b/fedmsg.d/endpoints.py
+index 72c182a..c4eab16 100644
+--- a/fedmsg.d/endpoints.py
++++ b/fedmsg.d/endpoints.py
+@@ -24,15 +24,15 @@ config = dict(
+ endpoints={
+ # These are here so your local box can listen to the upstream
+ # infrastructure's bus. Cool, right? :)
+- "fedora-infrastructure": [
+- "tcp://hub.fedoraproject.org:9940",
+- #"tcp://stg.fedoraproject.org:9940",
+- ],
++ #"fedora-infrastructure": [
++ # "tcp://hub.fedoraproject.org:9940",
++ # #"tcp://stg.fedoraproject.org:9940",
++ #],
+ #"debian-infrastructure": [
+ # "tcp://fedmsg.olasd.eu:9940",
+ #],
+- #"anitya-public-relay": [
+- # "tcp://release-monitoring.org:9940",
+- #],
++ "anitya-public-relay": [
++ "tcp://release-monitoring.org:9940",
++ ],
+ },
+ )
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/files/0.18.0-no_signatures.patch b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
new file mode 100644
index 000000000000..8be69ad5ba81
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
@@ -0,0 +1,29 @@
+From 8f61441ba94f7f0bd2b2a1c900e20db038b7085f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:23:58 +1300
+Subject: [PATCH 2/2] Disable signature validation
+
+Signature validation currently requires M2Crypto and M2Ext,
+which are *only* available on Python2
+
+Python3 Implementations of Signature Validation appear currently broken
+---
+ fedmsg.d/ssl.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fedmsg.d/ssl.py b/fedmsg.d/ssl.py
+index c148667..f635ffb 100644
+--- a/fedmsg.d/ssl.py
++++ b/fedmsg.d/ssl.py
+@@ -25,7 +25,7 @@ here = os.getcwd()
+
+ config = dict(
+ sign_messages=False,
+- validate_signatures=True,
++ validate_signatures=False,
+
+ # Use these implementations to sign and validate messages
+ crypto_backend='x509',
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/metadata.xml b/dev-python/fedmsg/metadata.xml
new file mode 100644
index 000000000000..5bc322e3720d
--- /dev/null
+++ b/dev-python/fedmsg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kentnl@gentoo.org</email>
+ <name>Kent Fredric</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">fedmsg</remote-id>
+ </upstream>
+</pkgmetadata>