summaryrefslogtreecommitdiff
path: root/dev-python/fedmsg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/fedmsg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/fedmsg')
-rw-r--r--dev-python/fedmsg/Manifest5
-rw-r--r--dev-python/fedmsg/fedmsg-0.18.3.ebuild40
-rw-r--r--dev-python/fedmsg/files/0.18.0-endpoints.patch39
-rw-r--r--dev-python/fedmsg/files/0.18.0-no_signatures.patch29
-rw-r--r--dev-python/fedmsg/metadata.xml14
5 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/fedmsg/Manifest b/dev-python/fedmsg/Manifest
new file mode 100644
index 000000000000..308e0ecfb188
--- /dev/null
+++ b/dev-python/fedmsg/Manifest
@@ -0,0 +1,5 @@
+AUX 0.18.0-endpoints.patch 1251 BLAKE2B 80b31a396cdc1731c1f27c7cb8999506fa14fb3c5fe1625dc9c6152d0b5f20e25f085c41f9affe3a1c0038e3f14f741f2b01df495d6f4e60955f95e738969c1d SHA512 43a3850690980556e7a5ca8ae83359c7f9ef40d6556b590715ae40b5f1dd64c57ae4eef4898c935a556dd4230c53c75c246294ad30daa5a9c505c7ed3b1e39b6
+AUX 0.18.0-no_signatures.patch 820 BLAKE2B 334bb323cef140b011abf9c082738e66cbc254f7cd263667a601d2ea2c4de5adbe7b6c905dcf4e28b286d8003a968f7de08020413190c12a9c01dd403952de92 SHA512 d4869a6140b9594a6079257c55c86934f67c3eb69230881014501aac4c500efca2d20f1a2d3a69dc122444f63d14a42c87ba7eb3fd9468c8568d592378c6791b
+DIST fedmsg-0.18.3.tar.gz 540686 BLAKE2B 5d6cef00a4c87c48e38e6b8fdc880dc8b7f1f3fb7b9829979a7d2dda368cdb990559a13a5e7c95c6fe46dbd34d68adb59d9b987f7a9ed71e0c046f487c082a85 SHA512 59418b4da151c71962bf7d4d5c5005716c41578673b4786b0a6de3928b24e3de2976878fd66580f02848d453df4588d26d484d5eaf594ba7f49b1ba3a1cb2b00
+EBUILD fedmsg-0.18.3.ebuild 1041 BLAKE2B 551303a341456f02c82d7fa4253a176682ce069125e28f39d29f8b7b95f8bb1a3169716cc853a318caff43836f136658f163d77cb843f503b3adada25a02a256 SHA512 2e6e23f172d423d20708aaa8ed5c23fdc21a774b88a6ff658c1e18b2e360682769277b1aa7be745fcbb39f4c74481d936bc52a2bd5deceefba5dde2757d9b357
+MISC metadata.xml 393 BLAKE2B d39ebbe4319ef5d0a883af556bf6d90c921dffea58f3e11ae07ac5602fa0af2255ed8c67d888c783c476b41f8ad997f3735397e23c6d8ee51a6161b34549191b SHA512 a26cb34971bbe8e273f3214ba98dee260a6175943d1c1cd2715b0ea7dfc9db1b18a615fa62617532ca0f6b2722992b6cb320b97339941a027bb58e2b6a458233
diff --git a/dev-python/fedmsg/fedmsg-0.18.3.ebuild b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
new file mode 100644
index 000000000000..4713bff3b3e1
--- /dev/null
+++ b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Fedora Messaging Client API"
+HOMEPAGE="http://www.fedmsg.com/ https://pypi.org/project/fedmsg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/0.18.0-endpoints.patch"
+ "${FILESDIR}/0.18.0-no_signatures.patch" )
+RDEPEND="
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/m2crypto[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}"
+DOCS=(
+ "README.rst" "CHANGELOG.rst"
+ #TODO: doc/ dir full of rst files
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /etc/
+ doins -r "${S}/fedmsg.d"
+}
diff --git a/dev-python/fedmsg/files/0.18.0-endpoints.patch b/dev-python/fedmsg/files/0.18.0-endpoints.patch
new file mode 100644
index 000000000000..857f6839b5e3
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-endpoints.patch
@@ -0,0 +1,39 @@
+From 8bc5cbaa977b8de962f68ef84f6c8fadcb369c85 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:12:20 +1300
+Subject: [PATCH 1/2] Adjust endpoints to be more suited to gentoo users
+
+---
+ fedmsg.d/endpoints.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/fedmsg.d/endpoints.py b/fedmsg.d/endpoints.py
+index 72c182a..c4eab16 100644
+--- a/fedmsg.d/endpoints.py
++++ b/fedmsg.d/endpoints.py
+@@ -24,15 +24,15 @@ config = dict(
+ endpoints={
+ # These are here so your local box can listen to the upstream
+ # infrastructure's bus. Cool, right? :)
+- "fedora-infrastructure": [
+- "tcp://hub.fedoraproject.org:9940",
+- #"tcp://stg.fedoraproject.org:9940",
+- ],
++ #"fedora-infrastructure": [
++ # "tcp://hub.fedoraproject.org:9940",
++ # #"tcp://stg.fedoraproject.org:9940",
++ #],
+ #"debian-infrastructure": [
+ # "tcp://fedmsg.olasd.eu:9940",
+ #],
+- #"anitya-public-relay": [
+- # "tcp://release-monitoring.org:9940",
+- #],
++ "anitya-public-relay": [
++ "tcp://release-monitoring.org:9940",
++ ],
+ },
+ )
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/files/0.18.0-no_signatures.patch b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
new file mode 100644
index 000000000000..8be69ad5ba81
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
@@ -0,0 +1,29 @@
+From 8f61441ba94f7f0bd2b2a1c900e20db038b7085f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:23:58 +1300
+Subject: [PATCH 2/2] Disable signature validation
+
+Signature validation currently requires M2Crypto and M2Ext,
+which are *only* available on Python2
+
+Python3 Implementations of Signature Validation appear currently broken
+---
+ fedmsg.d/ssl.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fedmsg.d/ssl.py b/fedmsg.d/ssl.py
+index c148667..f635ffb 100644
+--- a/fedmsg.d/ssl.py
++++ b/fedmsg.d/ssl.py
+@@ -25,7 +25,7 @@ here = os.getcwd()
+
+ config = dict(
+ sign_messages=False,
+- validate_signatures=True,
++ validate_signatures=False,
+
+ # Use these implementations to sign and validate messages
+ crypto_backend='x509',
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/metadata.xml b/dev-python/fedmsg/metadata.xml
new file mode 100644
index 000000000000..5bc322e3720d
--- /dev/null
+++ b/dev-python/fedmsg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kentnl@gentoo.org</email>
+ <name>Kent Fredric</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">fedmsg</remote-id>
+ </upstream>
+</pkgmetadata>