summaryrefslogtreecommitdiff
path: root/dev-python/fido2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/fido2
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest4
-rw-r--r--dev-python/fido2/fido2-0.9.1.ebuild53
-rw-r--r--dev-python/fido2/fido2-0.9.3.ebuild2
3 files changed, 2 insertions, 57 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 44b5b746fd36..98e2b18160f7 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,5 +1,3 @@
-DIST fido2-0.9.1.tar.gz 206395 BLAKE2B 9a9b5d0dd808de896c91aa605540a1968aab7ae543336521d4a206f27bcf836c57e88aa6cdd0bacf71db8d16a0f94c2f9c16b16ca415363fd0b5e145a448ec18 SHA512 cde8c247fe0875129a890866ab76d40b2bd6feee86ff1ccb4b9ec5e6dc037e569fc8d969b51a456b5e66c6f7c67e18d14c3917375d5de85bbe7da5af3254f797
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
-EBUILD fido2-0.9.1.ebuild 1331 BLAKE2B d65af450cbb2ccfb13c111c66d76ab42346205223ae47ffdb537617de2b611ea7cf8da0ad4243fc4851b883b555d28c1b34e4f08272f4248ce51cf6d1ed4b1ca SHA512 ad03b13e06e84b730ac5fc0e0c463f7faa7e241fc01185aad50b3f81dc3c8e034386aad20ca062ea90a51f6060ae29a87150cc3b9064163453b11bafd6711e5b
-EBUILD fido2-0.9.3.ebuild 1333 BLAKE2B ce78356ba9686834474f770999abece69ce4d9a70be3a6cc17bc8c0c622bf870250ac508d2d50317ce4928d27745e98d1c10923be66713febf0eba7b2136ce72 SHA512 4e3ae6ca991d1027252c9017c9c26fb8e15bcae97f8242c079414d3b72f3538b0cce2fd17eead05c62e4b125a36c36c7fada3bda9a7b3c15b1801f9af1ae8e9d
+EBUILD fido2-0.9.3.ebuild 1331 BLAKE2B d65af450cbb2ccfb13c111c66d76ab42346205223ae47ffdb537617de2b611ea7cf8da0ad4243fc4851b883b555d28c1b34e4f08272f4248ce51cf6d1ed4b1ca SHA512 ad03b13e06e84b730ac5fc0e0c463f7faa7e241fc01185aad50b3f81dc3c8e034386aad20ca062ea90a51f6060ae29a87150cc3b9064163453b11bafd6711e5b
MISC metadata.xml 820 BLAKE2B 092fc3aa0dc3e3a8998e7cef0a3229d5b8791983dc07df84c74ff6b7221afc879aa5a39a6ad58ff0bfe2836fa48b57d3445f20a0c78e2affc3bc47b73b81544b SHA512 f588e6637d75b668dabf80fc2c8e1133119a770d4f7fa5077025e0a478f8eb9c7f18eac1ce15395549485625bc4c82bdeebf07440087cd074e95d42a685eef53
diff --git a/dev-python/fido2/fido2-0.9.1.ebuild b/dev-python/fido2/fido2-0.9.1.ebuild
deleted file mode 100644
index 86f0257593d5..000000000000
--- a/dev-python/fido2/fido2-0.9.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based FIDO 2.0 library"
-HOMEPAGE="https://github.com/Yubico/python-fido2"
-SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
-SLOT="0/0.9" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="amd64 ~riscv x86"
-IUSE="examples"
-RESTRICT="test" # Tests require <dev-python/mock-4
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyscard[${PYTHON_USEDEP}]
- examples? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# Disable tests, <dev-python/mock-4 doesn't exist
-# DEPEND="${DEPEND}
-# test? (
-# ${RDEPEND}
-# <dev-python/mock-4[${PYTHON_USEDEP}]
-# >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
-# )
-# "
-#
-# When tests are available again, remember to add a custom
-# test phase that runs 'python -m unittest discover -v'
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r "${S}"/examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/dev-python/fido2/fido2-0.9.3.ebuild b/dev-python/fido2/fido2-0.9.3.ebuild
index b57545910a73..86f0257593d5 100644
--- a/dev-python/fido2/fido2-0.9.3.ebuild
+++ b/dev-python/fido2/fido2-0.9.3.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar
LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
SLOT="0/0.9" # Bumped every time a backwards-incompatible version is released
-KEYWORDS="~amd64 ~riscv ~x86"
+KEYWORDS="amd64 ~riscv x86"
IUSE="examples"
RESTRICT="test" # Tests require <dev-python/mock-4