summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
commit5264c18a325553759d67fb4e059db03cf3fc5c81 (patch)
tree588a7d54829b20df6c11016213dad5808b5c706a /dev-python/flake8
parent27b3683509c5229cce540418778a8b64afbc0009 (diff)
gentoo auto-resync : 18:02:2025 - 00:14:44
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-7.1.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 3fa68da7b78e..a46b3c87e2e8 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,5 @@
DIST flake8-7.1.1.gh.tar.gz 138915 BLAKE2B 5c00c4a95f0757f7d3716270ca1de91580cb1731c700227d563c08798981c124c5789f40a5965ad49450a77601ab9638d04cb32ef9c13418720c4123ba2a7932 SHA512 310457e3c701f746d812cc76664bcb79c7cbc320af9d757ebbc13c847f2c3864770d9b945694b4b6abb773ae636e19175222c3dab74d34559beaa7835f1d9931
+DIST flake8-7.1.2.gh.tar.gz 139099 BLAKE2B 4236a533cbaaa91c4c407af02890189ca65b7ebfe3af711df2cdba02e5a28963fc3622e0a0a41190168f3cd827ccb8fed4561cdcf352642f2660ec361657a43c SHA512 da90d07d45690efa433338ed6fcfaabdf08b5bf600783fa0f22b59f77bc560b81d3e0c8203c8fe92bd0b133f40fccd919d68c65cab9a266ea6f5bd45576b3837
EBUILD flake8-7.1.1.ebuild 1471 BLAKE2B 106f072702e210d335d75a605594a621740688e3a350189e18f22efb481781438b4dff313f3a177bb499481d7a0ed37e0722aded3e0624255d0288b69ed1b1e7 SHA512 8ec66d0f9c90e9f7d91ffd4a76145e7aed67c8eecd56ab450410b082c9fe8d74d12c05c3b361753f3a38c1447859e95d5d44d4560752989376bce9411125cbd7
+EBUILD flake8-7.1.2.ebuild 1479 BLAKE2B 8d1a3466a4dcf08c6feb4ba0b1a528ab6c8ec2f0d2aba58fc86d86e4c851e22ef20f4549e3ea6e073a6b64410118b09582f8627aa37366675422f71868f035fe SHA512 e7c2ffc3f92fb772453bd214bd453e109a6c8d62af0859c17e6c9e985cc163582776afa7e0520573e1edbfc4fbfeb08644bbb6e51b85add6dccad7d31561c983
MISC metadata.xml 399 BLAKE2B 01ae165c898af67195582e1aaf867b9f9fc937e56b87f09a812d21c9d1175131c25561524ba76857c1630a117a21bc43eeef907c2a34ab9e9b38866dc2f9430e SHA512 8f149a017f4fef8f8fe0fef037e589694e0c3b3689990f97f38ed23fb9b5c5170985fc1fd7814ef70b8200db66cb9367dcfc9bf6453f8742092335a1c3c8fae6
diff --git a/dev-python/flake8/flake8-7.1.2.ebuild b/dev-python/flake8/flake8-7.1.2.ebuild
new file mode 100644
index 000000000000..25cbc7ee4d1c
--- /dev/null
+++ b/dev-python/flake8/flake8-7.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/PyCQA/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ =dev-python/pyflakes-3.2*[${PYTHON_USEDEP}]
+ =dev-python/pycodestyle-2.12*[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ =dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-prompt \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+ )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # problem with pypy3.10 in dev-python/pyflakes
+ # https://github.com/PyCQA/pyflakes/issues/779
+ tests/integration/test_main.py::test_malformed_per_file_ignores_error
+ tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
+ tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
+ )
+ fi
+
+ epytest
+}