summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-25 14:56:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-25 14:56:25 +0100
commit5c42677148c717eb9f4673237db807f74740b4e9 (patch)
treeee9f721e91477693459f31721790f2f41839a74c /dev-python/flake8
parentc9b5a916efac64df2a39870a92cc6b67116d1b9f (diff)
gentoo auto-resync : 25:08:2024 - 14:56:25
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-7.1.0.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 4e5d846c1525..31c8c6f7cfc4 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,5 +1,3 @@
-DIST flake8-7.1.0.gh.tar.gz 138600 BLAKE2B df6781e676d4eccf296d5fc3d767643956799d1c99adccb32d0005951f0aca13b7e99ff7506f7026e9ed6c2dd78d5bdd02d9a25aaf64a1353097b8a9c02c5739 SHA512 0e970bdb0facff3a6e2ee33a74fe77ee1f7c80fbc517125df34d831ff897e222d0955d56fa9e9eedef83ccdc4e92aa7bbc583517d7b19a8cf1041790a225693a
DIST flake8-7.1.1.gh.tar.gz 138915 BLAKE2B 5c00c4a95f0757f7d3716270ca1de91580cb1731c700227d563c08798981c124c5789f40a5965ad49450a77601ab9638d04cb32ef9c13418720c4123ba2a7932 SHA512 310457e3c701f746d812cc76664bcb79c7cbc320af9d757ebbc13c847f2c3864770d9b945694b4b6abb773ae636e19175222c3dab74d34559beaa7835f1d9931
-EBUILD flake8-7.1.0.ebuild 1477 BLAKE2B dd6c68fe4a16963aa3a005e9d14ef974af0f87eb7fda94de0c7e0955f5c1169c0443735fb36be1fb35a627638b6639c114d118f5bcb6cbc5e057aae0d132fb06 SHA512 f30f0d4a2d0dd30af5fa51a49f8a7d2818fb7e05aee4f80e52d5663a085726f55dc9eccc8838b5b9d41a3908c1f559e33641086fac045e9bae3847fed99a58c3
EBUILD flake8-7.1.1.ebuild 1477 BLAKE2B dd6c68fe4a16963aa3a005e9d14ef974af0f87eb7fda94de0c7e0955f5c1169c0443735fb36be1fb35a627638b6639c114d118f5bcb6cbc5e057aae0d132fb06 SHA512 f30f0d4a2d0dd30af5fa51a49f8a7d2818fb7e05aee4f80e52d5663a085726f55dc9eccc8838b5b9d41a3908c1f559e33641086fac045e9bae3847fed99a58c3
MISC metadata.xml 399 BLAKE2B 01ae165c898af67195582e1aaf867b9f9fc937e56b87f09a812d21c9d1175131c25561524ba76857c1630a117a21bc43eeef907c2a34ab9e9b38866dc2f9430e SHA512 8f149a017f4fef8f8fe0fef037e589694e0c3b3689990f97f38ed23fb9b5c5170985fc1fd7814ef70b8200db66cb9367dcfc9bf6453f8742092335a1c3c8fae6
diff --git a/dev-python/flake8/flake8-7.1.0.ebuild b/dev-python/flake8/flake8-7.1.0.ebuild
deleted file mode 100644
index 32744afd4140..000000000000
--- a/dev-python/flake8/flake8-7.1.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="
- https://github.com/PyCQA/flake8/
- https://pypi.org/project/flake8/
-"
-SRC_URI="
- https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- =dev-python/pyflakes-3.2*[${PYTHON_USEDEP}]
- =dev-python/pycodestyle-2.12*[${PYTHON_USEDEP}]
-"
-PDEPEND="
- =dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- ${PDEPEND}
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-prompt \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fails if additional flake8 plugins are installed
- tests/integration/test_plugins.py::test_local_plugin_can_add_option
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- EPYTEST_DESELECT+=(
- # problem with pypy3.10 in dev-python/pyflakes
- # https://github.com/PyCQA/pyflakes/issues/779
- tests/integration/test_main.py::test_malformed_per_file_ignores_error
- tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
- tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
- )
- fi
-
- epytest
-}