summaryrefslogtreecommitdiff
path: root/dev-python/flaky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-python/flaky
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest2
-rw-r--r--dev-python/flaky/flaky-3.5.3.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index a270e5e42265..3eb76e442d2c 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1,5 +1,7 @@
DIST flaky-3.1.1.tar.gz 29136 BLAKE2B fe2f47356e0279885cc294f22bc4588b502c7ada1d3f7a3728b1e3127f011f5900187669bb4e0755e706a1bd77e1804c42986a07c6d3dc58fe085967adb6957c SHA512 039ad115a52b8b3a31bba045874e1860f1e04ea9cf878316226fb22af3c715b3893570c2f7380cf8467107f1a83a4ff69d0e9135daeb2dbea4b8f873a192815c
DIST flaky-3.4.0.tar.gz 29197 BLAKE2B 8f551a414cb06f5259d37785eb769a77105b1039398462288eeaeeb6acea8456c30cc7da6cf515cd99be2adb19a77282d2d0d3abe795761985f45ffd062de508 SHA512 14fda6312e4eb8260a8190204622a7dd274d0c946dda07ec8aa65e8c341f7f4a701c704c807f50eacf77589231b37c3bb06eec18d60a718f24e9b0182f7e8cb5
+DIST flaky-3.5.3.tar.gz 29320 BLAKE2B 6bd2095cd481fdd8311e08c3e8aaff78fe22bfefd8463ea3b8190a469d8f909039267256afa876a22a57eae9e390af8235b10211509fe8549d000ed7e9331baa SHA512 9ecb80ab1ec2e0db96b7a7a5856a147434c22d29a603e76d3db3f8d94ddea06ecab799943179910bc1d9d8d5dc1c7bcc94156628352479d67e2dcaaf5cbabf27
EBUILD flaky-3.1.1.ebuild 1388 BLAKE2B 058e0db9e1c5345bff3d535b695ec9c367dadd2cdddfc9e01cf5bc7804c2000f9049e5b88dbc7edce1f3ef29dbd47cb24bd0858d083fded692039df42bc4e26f SHA512 4e788de38ad4cfd9141983e33aa9c0e60aac16958f6f410cdf23afb5bc7838b50b631b8a55a37272381f211782c5084a732db8fdb2155c9cf88d79a2625b4b1c
EBUILD flaky-3.4.0.ebuild 1467 BLAKE2B 7f67f007889ef7c559c0fba0256319a79346a8186db576db9eba6ad05f6c5c52b008188245848dcc950f493e96da0acc00fd2c451b73a219c6a25c104945978f SHA512 0fe0a76cdf49f63716f30f6a3bf32f984490ddfe9f8af6ef85fdd6e863df4372024fa5e0715c915cd97e4697a26f5a551361f771e8df3f67c249fe7f5dd6cc68
+EBUILD flaky-3.5.3.ebuild 1467 BLAKE2B 17b642e76b2aa9455d2efa83de370fcf5f5214f3aa1828e36f21b5bd45747e526a3c9312154da7ce9d4c6e853230a53087e7891a3e5ea6f0f2a51abb4a316ff1 SHA512 d6d61a09254d22e84d81bd8c45a31f872f2078de3f487cae97999bef133a44a44ca4b3b54cc0d6c32da8e6439f0669828152f8305c15a6baf94f10cf7329eb4f
MISC metadata.xml 369 BLAKE2B ffa607acfbc98fc2e539492f87b55cedb039b39b3cdb7ce07cf9dcebe1a1559296284b27d06fc6262f362c0ea8577e23f4bef07ffd01a94c4d981fa060384d5a SHA512 da1597d14b2e3f9bc56e48064718a2a52bc1615d982d679d8c971f1fb1b9c25169d5412f99542f808fa42f958e1bb589e7615a13077a7d1b0574acbec1d4b1dd
diff --git a/dev-python/flaky/flaky-3.5.3.ebuild b/dev-python/flaky/flaky-3.5.3.ebuild
new file mode 100644
index 000000000000..92528305918e
--- /dev/null
+++ b/dev-python/flaky/flaky-3.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}