summaryrefslogtreecommitdiff
path: root/dev-python/flaky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
commited43421253416ff58a637be8932ac1d7b7b232de (patch)
tree3cf7b0046bd17c3d59b7621101a7fd606fc2662b /dev-python/flaky
parent2d644a12e4e4d5061eeff8d068db29d562eba35b (diff)
gentoo auto-resync : 03:03:2023 - 19:35:31
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest3
-rw-r--r--dev-python/flaky/flaky-3.7.0-r2.ebuild42
-rw-r--r--dev-python/flaky/flaky-3.7.0-r4.ebuild5
3 files changed, 3 insertions, 47 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index ff9955f18ed2..600172e552f6 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1,4 +1,3 @@
DIST flaky-3.7.0.tar.gz 29591 BLAKE2B 747fbda71055bba937abf3e7b97691c1f4b222f085069d1815d5a9eba669464d2ed5d6dcf1842ae82f1970de5cd5e3aea5b12476bfa2d9282549ad0cc62901e9 SHA512 b399f6e1323d6ca341803ac6f1eb318bf24dc37182d0b49b89bb81b9466dd36271ad6dbb9f48ea6fa4760ee631f1482bb6f49c64f4d4520c40634089c1b64f9a
-EBUILD flaky-3.7.0-r2.ebuild 1479 BLAKE2B 697b1233a66bd5f570aa6f33a028738f8a000a1d0b385f5ff6c53ab95178608283f9d72e5e20f1b644cb983e84cfa5fbd58aaafba29d97909057e368bcad5fab SHA512 e61bba90a429d0c0866c74d02e83c24bbb13feeee8a8e69e17d7876a86bc2c1a211a4f2780af68d501f8e0f6cf8071cd8d76b8891bd3be4a331f1d67398a249c
-EBUILD flaky-3.7.0-r4.ebuild 1207 BLAKE2B 36b26bd062ce177e8cb63e6979caef5308ded5c3c19f884fecc8fbeacec92c05403ce5101761a03d4f862925f4042fc8434500371bf1e68828ad18ce74e8a318 SHA512 ed6968e4ecb5d8ec3177ceebbb053723bcff05221f0737299f3e44f0c153bb0f53d1f4a86e07e95e984710532421d22affc281cd64ce8e18fd69e31ca3d2d93a
+EBUILD flaky-3.7.0-r4.ebuild 1152 BLAKE2B bb950f4b09ad622bd978469737f72b77dd38af340d3f023f9857a8fdc1c9036cf7fc478fd4cdf6da0fbb30bef45c1abbb3f6614e4a4265e95097b74e09efe3be SHA512 4f3ac46f416e7ecca86c04ce98b50c7f198c8296532ebc35de2850a0daf3f2959bf28e805cbfa2c9ea98e6f6fbf15700103d39f6b845e2e8fa7193c8c72d0d8c
MISC metadata.xml 395 BLAKE2B 06158c93157879bd7b181e833d84ea33a315103214cfaa54a092f965900f05f705183b74738543ac6bb83beb62de562a59ef43b734a74c9f3d0d5d677e8e00d1 SHA512 2d237ebccf03db7fc42fac5370f1046834646bdfc5755e2298e9cac131363e47e496d9d0f0d00ad914764bcbc2deaee8b7182ae3c32e18f95766351da50028aa
diff --git a/dev-python/flaky/flaky-3.7.0-r2.ebuild b/dev-python/flaky/flaky-3.7.0-r2.ebuild
deleted file mode 100644
index 789abd7f41c5..000000000000
--- a/dev-python/flaky/flaky-3.7.0-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
-HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-python/genty[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
- ' python3_{8..10} pypy3)
- )
-"
-
-python_test() {
- epytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
- epytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
- epytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
-
- # please keep this in sync with python_gen_cond_dep!
- if has "${EPYTHON}" python3_{8..10} pypy3; then
- "${EPYTHON}" -m nose --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
- "${EPYTHON}" -m nose --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
- fi
-}
diff --git a/dev-python/flaky/flaky-3.7.0-r4.ebuild b/dev-python/flaky/flaky-3.7.0-r4.ebuild
index b80e2f72f774..9f1df64da087 100644
--- a/dev-python/flaky/flaky-3.7.0-r4.ebuild
+++ b/dev-python/flaky/flaky-3.7.0-r4.ebuild
@@ -6,18 +6,17 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Plugin for pytest that automatically reruns flaky tests"
HOMEPAGE="
https://github.com/box/flaky/
https://pypi.org/project/flaky/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="Apache-2.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"