summaryrefslogtreecommitdiff
path: root/dev-python/flask-appconfig
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/flask-appconfig
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/flask-appconfig')
-rw-r--r--dev-python/flask-appconfig/Manifest5
-rw-r--r--dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild53
-rw-r--r--dev-python/flask-appconfig/flask-appconfig-0.11.1.ebuild51
-rw-r--r--dev-python/flask-appconfig/metadata.xml17
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/flask-appconfig/Manifest b/dev-python/flask-appconfig/Manifest
new file mode 100644
index 000000000000..5f7bd8ceca50
--- /dev/null
+++ b/dev-python/flask-appconfig/Manifest
@@ -0,0 +1,5 @@
+DIST flask-appconfig-0.11.1.tar.gz 14545 SHA256 9869a752692e56f35ed3b017ea0e5b1d4b918a23bac8bc98a9e41ab54f5a9902 SHA512 9ebc42be5ef247b1f14b85f7b65600a1595ecdc70e792c0cd495347254b07675a3b7a306df8d2f2663626ceafa4ce7700f6f26cd0f1bcd974ba6bbab293847ee WHIRLPOOL f59662f9e7ace02e1e8dfc1a0a99b40c0cc5a353782d925d71e528fecc73ffbcea2891f99c3a1d20900f5b4f4064be9981f04ec20519aa74e2f872e8167b7da3
+EBUILD flask-appconfig-0.11.1-r1.ebuild 1293 SHA256 76402d5c8f3c584042b1b78b93d690ad85906b2e5698548415cf9e846dae50df SHA512 834c004413be8a0a5148aaf7b4d31a46ec1dbe77d828127bb57243301c735fb4699571cbfeb222770abf970f124bb2fbf7c60d973c989131bfe4f1238bdb9571 WHIRLPOOL 7502d22bc3be4682b4fbf6673b15f24682bb959826becce708b2346fafcb87dd06ab2b613c1ff9facbd4f51b473a511e3b54024132aa79aae30cc888d22299b0
+EBUILD flask-appconfig-0.11.1.ebuild 1189 SHA256 6b62ef5de9bda54c9aa600d837b016c2f37b814485604dde0a597d885b7c9ad0 SHA512 aa7836360cbb4de89fed9ffabe2313b4ab2f582e072cfee815304eca0fd2dd1e320674ae029572554cf46bb11c72aa6437f9a7de46d9e09d246b293ab2e8069d WHIRLPOOL 7d473a07c8f8b8770c044fee92fb380dd1178e3ebb33a8d8fbe0cbfbf4b61a948a03276d6ae2692a70f52e10e7f4c6d4956f3a951208b7cd48f66cb29ccf5bd5
+MISC ChangeLog 1087 SHA256 1f15b4ef11cf5b55e884295d0338efc277fabe00953d54072c950100457062b7 SHA512 3c571cc521bc551a2faf2a3c67dd6d4b994fa0c69fff06c0d4ffc85866f3fa3c297aaf3498ed43a26865586b955d14297036a018d284a1309d499cd0ece1891c WHIRLPOOL 7fd18ecbb786c1a7e8ea15ffbe9fa422a4254882770d8c33763df18c5ae71f35ff1ef45e28af1df595e6ffe081be344ac6f76b15169534c8b872b4a7a114bf11
+MISC metadata.xml 573 SHA256 e8689590d0c8a60aba9adc8c06b658886486404f3c549236e29d34c88e714aaf SHA512 77d7130b75896a8a317f3ee741e0bd1c9b0c0d3acecc183985bb8330a7b6010174eff3631c98b706b28af17790926bdba275a6e9a05b5b799eec7b04e4e8e6d9 WHIRLPOOL e6b113d626a9505b15b9e2be89287e4bd71b367450b9fc618f7e7f4798d13a65920a792e2849f026744ca109a862f6a64d5134b435a5a548e2106c80e98513cc
diff --git a/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..66d2f6d35180
--- /dev/null
+++ b/dev-python/flask-appconfig/flask-appconfig-0.11.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Configures Flask applications in a canonical way"
+HOMEPAGE="https://github.com/mbr/flask-appconfig"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-appconfig/pull/4
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ # These conflict with recent flask versions, #589548
+ sed -i '/entry_points={/,/},$/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-appconfig/flask-appconfig-0.11.1.ebuild b/dev-python/flask-appconfig/flask-appconfig-0.11.1.ebuild
new file mode 100644
index 000000000000..c543bd77e196
--- /dev/null
+++ b/dev-python/flask-appconfig/flask-appconfig-0.11.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Configures Flask applications in a canonical way"
+HOMEPAGE="https://github.com/mbr/flask-appconfig"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-appconfig/pull/4
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-appconfig/metadata.xml b/dev-python/flask-appconfig/metadata.xml
new file mode 100644
index 000000000000..8639b4a6ed3a
--- /dev/null
+++ b/dev-python/flask-appconfig/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">flask-appconfig</remote-id>
+ <remote-id type="github">mbr/flask-appconfig</remote-id>
+ <bugs-to>https://github.com/mbr/flask-appconfig/issues</bugs-to>
+ </upstream>
+</pkgmetadata>