summaryrefslogtreecommitdiff
path: root/dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-07 15:25:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-07 15:25:19 +0000
commit54ef05621701a320a71e56f68a0a942bc53ae0e9 (patch)
tree1137ddce6287c914945a29436a5741aee8f7fea5 /dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild
parent077e0e831423827ec97c98a46b5f2cc03fb4a6ea (diff)
gentoo auto-resync : 07:02:2023 - 15:25:18
Diffstat (limited to 'dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild')
-rw-r--r--dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild b/dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..914d55fc495d
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-3.0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="
+ https://python-babel.github.io/flask-babel/
+ https://github.com/python-babel/flask-babel/
+ https://pypi.org/project/flask-babel/
+"
+SRC_URI="
+ https://github.com/python-babel/flask-babel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/Babel-3[${PYTHON_USEDEP}]
+ <dev-python/flask-3[${PYTHON_USEDEP}]
+ <dev-python/jinja-4[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/python-babel/flask-babel/pull/215
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ distutils-r1_src_prepare
+}