summaryrefslogtreecommitdiff
path: root/dev-python/flask-debug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flask-debug
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-debug')
-rw-r--r--dev-python/flask-debug/Manifest3
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3.ebuild51
-rw-r--r--dev-python/flask-debug/metadata.xml13
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/flask-debug/Manifest b/dev-python/flask-debug/Manifest
new file mode 100644
index 000000000000..094e26d62cf4
--- /dev/null
+++ b/dev-python/flask-debug/Manifest
@@ -0,0 +1,3 @@
+DIST flask-debug-0.4.3.tar.gz 9148 BLAKE2B 9263a4df08f1a9518a42a025a14a89b902c62ab08b25d79b3dfffb25675a47785d0bf9075290190ee4622a30a89e190a465a87986b47ceed7d724ce0b59ad218 SHA512 7bc1cf9f88f28e2ca5a24c1454dcdb4e2a450eff3c00329f299c3840032e0803079f565652974f4c3a0e5aac443365ce47a3d2c2fee8e21e2e0c7150367e8816
+EBUILD flask-debug-0.4.3.ebuild 1195 BLAKE2B bd2b740de12688eeeb31784a122547f62aebde2530dfc0043334b1c44fbf93864b6a32b740f06a83aef254956ef50dfcbdacbdf84f652ce307080463e4ebadf3 SHA512 272e1a8931a0c8e7d9762cc3608105037c9c696d81d4848386ed99184a66ad8116ecbab63954dad4221e6c198d5aaf0b2f1dabd5e4baefabdb07a0e7de07b63d
+MISC metadata.xml 437 BLAKE2B a47818cc11d0365a7a03da5ea3c9fa7bb60d3ec783d63bd8780e11db56dd2093e39ecf4633f462f17cf95e97c93dfbc64301c1c321450a985dcfe28bd6a1bbb5 SHA512 93d72b4859ed2838632f65de971957dc279ccb5897b703b61baf5287a5748f33a7b94f484f8f457b6e4a4e7c5c25e7a5f35506c86e3f539ad7240bbc66748398
diff --git a/dev-python/flask-debug/flask-debug-0.4.3.ebuild b/dev-python/flask-debug/flask-debug-0.4.3.ebuild
new file mode 100644
index 000000000000..cccb072ac7a3
--- /dev/null
+++ b/dev-python/flask-debug/flask-debug-0.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Debug"
+DESCRIPTION="Flask extension that displays various debugging insights during development"
+HOMEPAGE="https://github.com/mbr/Flask-Debug"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/Flask-Debug/pull/2
+SRC_URI="https://github.com/mbr/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-debug/metadata.xml b/dev-python/flask-debug/metadata.xml
new file mode 100644
index 000000000000..b409b5ff6b39
--- /dev/null
+++ b/dev-python/flask-debug/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Debug</remote-id>
+ <remote-id type="github">mbr/Flask-Debug</remote-id>
+ <bugs-to>https://github.com/mbr/Flask-Debug/issues</bugs-to>
+ </upstream>
+</pkgmetadata>