summaryrefslogtreecommitdiff
path: root/dev-python/flask-security
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/flask-security
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/Manifest4
-rw-r--r--dev-python/flask-security/flask-security-3.4.4.ebuild5
-rw-r--r--dev-python/flask-security/flask-security-3.4.5.ebuild74
3 files changed, 80 insertions, 3 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index b0a942270695..4deca8199aa2 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1,4 +1,6 @@
AUX flask-security-3.4.3-optional-deps.patch 2287 BLAKE2B 5cd174499a3fc22e0888850332ccd0798927a3127d6b84b19dae2ae1cbb8c998b6e8e5246a76eb84712d932f80c77316201834ee048c05c2de6e190bf9aafed6 SHA512 08b0ebfadbf126d1c4dfbc51d222f5da797c40bafc11c923eb2a98c3f65778f2f5400e0ced37c5fc6318a7941dd036ae780dbc958980620bd075f0212c0ea49d
DIST flask-security-3.4.4.gh.tar.gz 348525 BLAKE2B 77a851c2549be9ce8612e3b186ad2d83d272b277f286885da491f3f0fe99e8836d145749ae137f1e75625c34b2214270ba4d24f1bfaa514012064dd38f083230 SHA512 1c1a4f079199704d7a2a4e11351cd199e3a790f5d0c7f68b240c299e83b129227fac4ca00caf45401efbf14520c1d65d3b710b85e8f53b495283b94a164f97a2
-EBUILD flask-security-3.4.4.ebuild 2142 BLAKE2B ec9d9aba810b228ac39c65b151b6d89ad15f0749b2908fbde50cc4af7f5ab9fd41d000c9e93cfeb8e4f840757d26f70bc30ae19015a955602ae1df9e9ffa0ece SHA512 074acb81070b082e9bc7f31f316da2c0461688a6cbfef7bf3b16577f6582ccd6ac0322fee00ca3cffea4ee812bdb25feacf4113bdb708b09fc86503632aa952e
+DIST flask-security-3.4.5.gh.tar.gz 348928 BLAKE2B 9890227e9775c4a28fc364affb0bf767407463d514f6dc3cd359dd8a026e8325d943a547f294f6363a276f9e7d97336c526dd45f4549c7cfaff2d6ef9ef0316a SHA512 f9ac7f46b2e1ab7dbb44ba925b01e16304e8f8d6d5d56f4e558d07b80dfffa59f04c2597e17c00a7d7ae11be3a97c78ccf8d79993b7451be4a7f75f85bc89f6f
+EBUILD flask-security-3.4.4.ebuild 2191 BLAKE2B f4e7da22ec7a5b041df868676bd2cc3ed6323118c4ba7ca540e81bebd29795c2511c352e9cbfc501bf1ace1ada29f973c1d2ef72fd8d7d6c66ea14669f0d121e SHA512 9186b6313b6318c06cc0b220b57e5af210cf422a41fdd0b3f5abc7d2fe901d79cb27810e593376cbc602bbeb468d912467fda8efc305af65790953c75b9b30ec
+EBUILD flask-security-3.4.5.ebuild 2191 BLAKE2B f4e7da22ec7a5b041df868676bd2cc3ed6323118c4ba7ca540e81bebd29795c2511c352e9cbfc501bf1ace1ada29f973c1d2ef72fd8d7d6c66ea14669f0d121e SHA512 9186b6313b6318c06cc0b220b57e5af210cf422a41fdd0b3f5abc7d2fe901d79cb27810e593376cbc602bbeb468d912467fda8efc305af65790953c75b9b30ec
MISC metadata.xml 416 BLAKE2B 1da613b370aed838bdfe6ffaa616c80aca54cab6030680212db38c0bf1ff783d24db11d8dd2056843621668b25ccba850b2c3d6d62b378ade78f88b263c5573d SHA512 3ab74e9f590c343323fd3d9438bf2a487b77019eeb986e4a0f461c991a00075a70246812cde79f27a337c6ba385e162148a4382063888ff7f2fcf8405bf9573a
diff --git a/dev-python/flask-security/flask-security-3.4.4.ebuild b/dev-python/flask-security/flask-security-3.4.4.ebuild
index acca5c68373b..f13585ae3b47 100644
--- a/dev-python/flask-security/flask-security-3.4.4.ebuild
+++ b/dev-python/flask-security/flask-security-3.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,7 @@ BDEPEND="
>=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
>=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}]
>=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
>=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
>=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
@@ -59,7 +60,7 @@ PATCHES=(
src_prepare() {
sed -i -e '/setup_requires/d' setup.py || die
- sed -e 's:--cov flask_security::' \
+ sed -e 's@--cov flask_security@-p no:httpbin@' \
-e 's:--cov-report term-missing::' \
-e 's:--black::' \
-e 's:--flake8::' \
diff --git a/dev-python/flask-security/flask-security-3.4.5.ebuild b/dev-python/flask-security/flask-security-3.4.5.ebuild
new file mode 100644
index 000000000000..f13585ae3b47
--- /dev/null
+++ b/dev-python/flask-security/flask-security-3.4.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="
+ https://github.com/Flask-Middleware/flask-security/
+ https://pypi.org/project/Flask-Security-Too/"
+SRC_URI="
+ https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.14.2[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.0.5[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
+ >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
+ >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
+ >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4.3-optional-deps.patch
+)
+
+src_prepare() {
+ sed -i -e '/setup_requires/d' setup.py || die
+ sed -e 's@--cov flask_security@-p no:httpbin@' \
+ -e 's:--cov-report term-missing::' \
+ -e 's:--black::' \
+ -e 's:--flake8::' \
+ -e 's:--cache-clear::' \
+ -i pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ esetup.py compile_catalog
+}