summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-15 03:02:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-15 03:02:36 +0000
commit57d1fe5ae0c56e604db5d29bf7b62d685c42e043 (patch)
treebc1bdf3c531b7b4cef73b051dbb3cd439dee4a39 /dev-python/flask
parentd3c7d3e5f9607edef1a795ccc502ab3eb3121165 (diff)
gentoo auto-resync : 15:11:2024 - 03:02:36
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest2
-rw-r--r--dev-python/flask/flask-3.1.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 84d08346413b..67522e16f342 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,3 +1,5 @@
DIST flask-3.0.3.tar.gz 676315 BLAKE2B 19013ff4588dc057febe2720eadcfcadb0e1854731c2c9e391449696549106da930c11f94782610424ea40c1377e9b8aa52ca39fedc6ad0c98c9a70a56d01514 SHA512 977c0e5fd2d496fae8e34a035f211118642dc6518a14dc5f6c175b72c6a76407aeb9ff0ed1f5db636370a9aa7e0d36baa783713ea7bdabd7f28c8c2b94643cd1
+DIST flask-3.1.0.tar.gz 680824 BLAKE2B 2897fb3cc7631341001c955119bf0a697db1a9dfd6ff0e1078f882fb030779eb0d15c64d4e9626d6a54bc50627c463f73d58b34e449b149106ac76ff878cd506 SHA512 dd1d9113f57d62cd8fb5d33a6fb6258761a39c3df41d174e52f454abfbfc2da4b6a88b142196bd0681637fe53982d95762b023acddbed00f10805c4266194e24
EBUILD flask-3.0.3.ebuild 1363 BLAKE2B 00dcab623a0d0faa486e3699b676757a3e56517023010e79dc635076377f74828ab354977bd198198d0c5e0668049c1ec6576a773737bd049f24d4a9602ce404 SHA512 150e0ba03050f530d3a060b97320d46123a1e674ba591358dfea73cc069a52eb72a81d2e05896d8af649b6b6c8eae1f14ca8e834c0e377f14399050c2d6a4cf7
+EBUILD flask-3.1.0.ebuild 1365 BLAKE2B 3667c9601091b4f82d35bb16e31186eb83daa4cad05e0d74b86a3ee4f38328995dc9f85cfc299f8cd0299acb326c71c2058ea9ddaf972e3593be79a442447e8a SHA512 545d73a6a878a398389eb124a7d7e69ac53f8213d757fa920508bbc6613258a612c76842b4ce8ec567dd2fb075ff98d9a007d52985345a2dd2429be0cfed8f63
MISC metadata.xml 386 BLAKE2B b449c54b966bc8943f7b7b12d6126867a89a2759eb749c08f7ad53a174e93ecad07f09b5e30c8562c63ab05df75a82e2f48f550ea8cf3a546f5afc2eef5a896d SHA512 123334db31948046e47f3cdbe0237cdec3dc2207485c8243d1e34e065436995423b6a89909563a6158741a8cc62a7fdad95923870a7114cf69e58ef715e7ec5c
diff --git a/dev-python/flask/flask-3.1.0.ebuild b/dev-python/flask/flask-3.1.0.ebuild
new file mode 100644
index 000000000000..53dd8cefc48c
--- /dev/null
+++ b/dev-python/flask/flask-3.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="
+ https://palletsprojects.com/p/flask/
+ https://github.com/pallets/flask/
+ https://pypi.org/project/Flask/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/blinker-1.9[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs \
+ dev-python/sphinxcontrib-log-cabinet
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}