summaryrefslogtreecommitdiff
path: root/dev-python/fleep/fleep-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/fleep/fleep-1.0.1-r1.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/fleep/fleep-1.0.1-r1.ebuild')
-rw-r--r--dev-python/fleep/fleep-1.0.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/fleep/fleep-1.0.1-r1.ebuild b/dev-python/fleep/fleep-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..cce82c31af2c
--- /dev/null
+++ b/dev-python/fleep/fleep-1.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
+ inherit git-r3
+else
+ # upstream aren't tagging the releases, just as commit title
+ COMMIT="994bc2c274482d80ab13d89d8f7343eb316d3e44"
+ # Note: On next bump, remove gh suffix from SRC_URI - was added just for tests
+ SRC_URI="https://github.com/floyernick/fleep-py/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/fleep-py-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="File format determination library for Python"
+HOMEPAGE="https://github.com/floyernick/fleep-py"
+
+LICENSE="MIT"
+SLOT="0"
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" maintest.py || die "Tests fail with ${EPYTHON}"
+}