summaryrefslogtreecommitdiff
path: root/dev-python/flit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-09 01:48:35 +0000
commit0b832a429ecd6081aa9faa0eb262303b019d87ea (patch)
treec39bb9eaa7bc30cec17f3a3bdef0cf5ed27c6a75 /dev-python/flit
parent80e87db4d9ed551615eb2d0309bf370e79500716 (diff)
gentoo auto-resync : 09:03:2025 - 01:48:35
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest2
-rw-r--r--dev-python/flit/flit-3.10.1.ebuild57
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 128d75e32d44..05c4cdecebbe 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,5 +1,3 @@
-DIST flit-3.10.1.tar.gz 143162 BLAKE2B d98c18a161380c2eb605083a700d7f5226fdc08f72defe9fd60cc8dba5947e9904d4a4df05a9620ef2fcbef8c4913f596b19ef365df7614c4fba7434acc764fd SHA512 37ff7e4de10d4b123cee854e692511574748a050d177e50f06330223ae94a4347e358ff07ca9545c3c8346c51c6734227808929f59401fdd062498d6bf69209a
DIST flit-3.11.0.tar.gz 153236 BLAKE2B b06660e1b57279b0d855dad6116e25115c9c52eae5fb8654b79608661affff8e98a2aaf011c0cb4eb940047a6d219825382e3db6266a6a1cc919bb16c6fadf67 SHA512 704774ab9b8154056a82f59814c2589ad4b3c8593a8e0de75eae99b1517211790604988efaf4f32e5f49fd472ec00efe8269b72524f285a647f4b8126699a4b7
-EBUILD flit-3.10.1.ebuild 1409 BLAKE2B 7575d28e1856f62482e7f77547f60d9b9e0ac31844c8483520f3f30e1713fc97b38d7faefc5b2140d2bb2ee2e2c44d4625b11a22527ce98f8e2bf981a74d471e SHA512 0797d3977bddc784ca234b4033db672da49e656dcaf3a83fa54bce81c7660c9ddfa63e62798b7fc8f36f1e692e367ab2d346906dd2286427e0705b91fa8fc9cd
EBUILD flit-3.11.0.ebuild 1420 BLAKE2B 4f1817b32c72f9965ffb2400318dc6374b6fcf76d8b36f6f3a6564c108d68a93487c2f82b6b76307ac270c6bea8354a6fdffa1f201ed2e5153bc222385928dea SHA512 61227dfb624a094fee18e3324ffdedbbbdccff06e221236093a0d87f1765790e292600ef31af8181ac8f8d4616803ca62dcb674e2014ac61ed2fc732e5272b4d
MISC metadata.xml 467 BLAKE2B 534a82783fa3ff1642fc8400689549e75223fa01b175f4ac164d4a636a4c9eaef5bdd9fdd339ffc30239436449788b4d01ebc5e3609034d440c01a5c699176ea SHA512 ad8f3f98a35aa88255bafa81ea9cb109e14b8a544b053cff3f1325dfda3c4c6343a5060353c43a08e030e80a60186eb7dae248d7f6739ea95a7e72e747b1b194
diff --git a/dev-python/flit/flit-3.10.1.ebuild b/dev-python/flit/flit-3.10.1.ebuild
deleted file mode 100644
index 14958054148d..000000000000
--- a/dev-python/flit/flit-3.10.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simplified packaging of Python modules"
-HOMEPAGE="
- https://github.com/pypa/flit/
- https://flit.readthedocs.io/
- https://pypi.org/project/flit/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~x86"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/flit-core-${PV}[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- sys-apps/grep
- test? (
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # requires Internet
- tests/test_config.py::test_invalid_classifier
- # failing due to Gentoo pip patches
- tests/test_install.py::InstallTests::test_install_data_dir
- tests/test_install.py::InstallTests::test_install_module_pep621
- tests/test_install.py::InstallTests::test_symlink_data_dir
- tests/test_install.py::InstallTests::test_symlink_module_pep621
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc \
- dev-python/sphinxcontrib-github-alt \
- dev-python/pygments-github-lexers \
- dev-python/sphinx-rtd-theme
-
-src_prepare() {
- # make sure system install is used
- rm -r flit_core || die
- distutils-r1_src_prepare
-}