summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-17 22:53:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-17 22:53:55 +0000
commit3d3cca628d8563ee68902105ad2e8e8bf0d7db2b (patch)
tree5c9f42e5ea285adfe047dbdea974e05ca37b5706 /dev-python/fonttools
parent1fca4db26fb13c520980473abebd51f620d34531 (diff)
gentoo auto-resync : 17:11:2023 - 22:53:55
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.44.3.ebuild38
2 files changed, 27 insertions, 13 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 920d891991c6..a53c33d7356b 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -5,5 +5,5 @@ DIST fonttools-4.44.3.gh.tar.gz 3775926 BLAKE2B fcc482ffa6163f895cf6ea8721dae3ce
EBUILD fonttools-4.43.1.ebuild 1627 BLAKE2B 1e3e29d8b99ba2ddd7b9d54d8c28e0463fe726d32e71afe8af52d72c82928dda98a12979fd1f6e7e200da88f75d0e20c5b72d5f64be989b2c2dddcd65a77a8e6 SHA512 9de4ba39052accc56cc887fab19a97e4497597eebbec9c20830f282428edf80436fe6425459ff8f7efb5e088c4fdecd96744f76898cef2816228867e963b6f61
EBUILD fonttools-4.44.0.ebuild 1833 BLAKE2B 66dd265b53dbfa2d0ff3d66d9f855bd3f70824ccbf3e5a967543b5fce69ddb0eac216dca934161f3f52d3c58ba1b6fc33c7c69bd29fc82e3b38396d7f3c5baf4 SHA512 38000e77ffa0fdb497f88c4eee65e505ffbc34620821d8bd471cbd3fc94e968e22b3f3c90d63af0993c796a66b5c78c6456cb9412c1eb9d63630e2fb05231ee4
EBUILD fonttools-4.44.1.ebuild 1833 BLAKE2B 66dd265b53dbfa2d0ff3d66d9f855bd3f70824ccbf3e5a967543b5fce69ddb0eac216dca934161f3f52d3c58ba1b6fc33c7c69bd29fc82e3b38396d7f3c5baf4 SHA512 38000e77ffa0fdb497f88c4eee65e505ffbc34620821d8bd471cbd3fc94e968e22b3f3c90d63af0993c796a66b5c78c6456cb9412c1eb9d63630e2fb05231ee4
-EBUILD fonttools-4.44.3.ebuild 1833 BLAKE2B 66dd265b53dbfa2d0ff3d66d9f855bd3f70824ccbf3e5a967543b5fce69ddb0eac216dca934161f3f52d3c58ba1b6fc33c7c69bd29fc82e3b38396d7f3c5baf4 SHA512 38000e77ffa0fdb497f88c4eee65e505ffbc34620821d8bd471cbd3fc94e968e22b3f3c90d63af0993c796a66b5c78c6456cb9412c1eb9d63630e2fb05231ee4
+EBUILD fonttools-4.44.3.ebuild 2175 BLAKE2B 21eb3e8cdcee3c522ce2bfd40744ff187136cc88718699812ec6716976a0dc7d87ee601c5eb4534ef882d13495024a0ac924128513d0a44ab92da3a3f5aae098 SHA512 be23a7914451efc0ab1e733fe68bc49e6381ab8f000138ec7bf19089b82fd1e3c37f6f3e63edcfee3349f7ebfbba0fd8f37db767f9d6abb78b9568261cee4728
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.44.3.ebuild b/dev-python/fonttools/fonttools-4.44.3.ebuild
index eb45479d5b14..f21d112c4c8b 100644
--- a/dev-python/fonttools/fonttools-4.44.3.ebuild
+++ b/dev-python/fonttools/fonttools-4.44.3.ebuild
@@ -5,10 +5,10 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
-inherit distutils-r1 multiprocessing virtualx
+inherit distutils-r1 virtualx
DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
HOMEPAGE="
@@ -23,20 +23,24 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="+native-extensions"
RDEPEND="
>=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
test? (
- app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
app-arch/zopfli
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
python_prepare_all() {
@@ -55,8 +59,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-src_configure() {
- export FONTTOOLS_WITH_CYTHON=1
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
}
src_test() {
@@ -65,9 +71,17 @@ src_test() {
}
python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]"
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest Tests fontTools \
- -p rerunfailures --reruns=5 \
- -p xdist -n "$(makeopts_jobs)" --dist=worksteal ||
- die "Tests failed with ${EPYTHON}"
+ nonfatal epytest Tests fontTools || die -n "Tests failed with ${EPYTHON}"
}