summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
commit4187bba080530c5ca1c7dae9c233e88f3fc8f535 (patch)
treeb6f535e053876097ced1b6bda14a4da890c730d4 /dev-python/fonttools
parent2a8d2f71d1d9963368e0ef3d641d75979a689d12 (diff)
gentoo auto-resync : 06:07:2024 - 08:06:15
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.53.1.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index ca326d355b71..041930b57662 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,7 @@
DIST fonttools-4.51.0.gh.tar.gz 3826324 BLAKE2B 84485874ce373ef759746104f8c0593d63e2955427a1606404e56ae006342fef39e3fe9468d85b974741ae26a8cceba23ea46e33fff0e2648c154074b01b5eac SHA512 3a9984b56a8ed1e918781c8503dd8901276ae7e20659777ff0a9bf799a42b4ec112a6cfd31deb81f73f7f19c03145a66962187fb243b2580db9d3ef7011d3d82
DIST fonttools-4.53.0.gh.tar.gz 3847778 BLAKE2B 31cf6e495441aeee90f96d6f96b9eedb581f3ee7e5e6f00f7df41547738e7da24d58b4aeac691c44961f842bbf347b32965b052d84ced88c7ade9c0d95c0367a SHA512 f810c428680c4203af3450c4a4b3a1d0f3f5e06ec7d7aac65e1e4aadf5d1e98f9efa5fed75388c8b0a0dcef5094d9b0586c0a71587360bafc91ad683a961698a
+DIST fonttools-4.53.1.gh.tar.gz 3850978 BLAKE2B 9c6b5af2cbde939b82043e29ffbbb23434c7b4bb7d7ce68385de701cdf97792bfb58b39acf5e0843493d4b4c3b70f76df6194c9a2ba4f4dfa7ec46155b9f8ce0 SHA512 c51a439c4c760bc929359ff3010612d00280ff1bfa8e6dd5248f181b3244239b82089727b4b6c81594fec57407f4c20f95497e0e26fe0e75fde30f8680022d07
EBUILD fonttools-4.51.0.ebuild 2464 BLAKE2B 29ca95c136616778810dafcebe6fc0b39b81bae3f858129cdc49e4710355d725b4a50616c4ab6ff237c5cc54b4abe244a3ac1383382a1a91c6c8296a42566ad9 SHA512 c305e19e347b2caa371b313f5569caaabe63b453c5a41cfcc98f437784e19622b50a947c1be1e96664a9a9ff2668c58fee63915beec5d16bc59b53caa2dbea3e
EBUILD fonttools-4.53.0.ebuild 2486 BLAKE2B aa00742ad8fc714894e5d76cc94afad8f17ef431826d79e76063e8049f617bfe4508d23cd88c3baaa5cec94c3f70a9c5065ffc6cc8009c46b372f63d7aa7ac17 SHA512 54a0a1ef47f9831ece9ccffc8351586a996d029427803ba6cf1d82014dc3891d85c5a6a9f806744835fdd22399ed76dfef810c3a87a82600e7a942e72d80dc2a
+EBUILD fonttools-4.53.1.ebuild 2493 BLAKE2B e0c62d22bc509c5f87c0571df221a2b50a915f572f619667e8ce884d5c1cfb2848f78f0f0ef6ec9d9ca6967ebeb969b1777ac2b56fc10eab17b61b182dbf2abf SHA512 93ad9b0c1260406510000be40d18d236d0653e0a6b8262d5cad38e760eb7a137f5e92bb98a35601794969510afc21dc905bbc6a836a551049af528767808e5b4
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.53.1.ebuild b/dev-python/fonttools/fonttools-4.53.1.ebuild
new file mode 100644
index 000000000000..0ad854ad63fc
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.53.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}