summaryrefslogtreecommitdiff
path: root/dev-python/foolscap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/foolscap
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/foolscap')
-rw-r--r--dev-python/foolscap/Manifest2
-rw-r--r--dev-python/foolscap/foolscap-0.13.1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/foolscap/Manifest b/dev-python/foolscap/Manifest
index 3dce79d33a52..5792816b211d 100644
--- a/dev-python/foolscap/Manifest
+++ b/dev-python/foolscap/Manifest
@@ -1,5 +1,7 @@
DIST foolscap-0.11.0.tar.gz 491916 BLAKE2B bf36442b4274943c00df244c2880dbf8f16b67288a6b8391c8f3e8547ab907ff6de3e1dd92e7173c5801349d1f04f3789ef1f95b5baa32dadc3c56d3dd5b5d0e SHA512 577cd15e7f9207a9675999590cb1189edbdd77a2daee5cab80d66d40b1343bcb338a064eedf372ca7f8a102ed1cef0770923d6dea27dd6c3b37c0717cdc912e8
+DIST foolscap-0.13.1.tar.gz 524167 BLAKE2B 4d68b0a969dc90fdabadc38ceb7a912f7e0c25f2c1206d4613d3bc314a907832de02656c32f32bd2361e519476e1178a80c2d4ade7fc1f17caeb6ab7b4b72dfc SHA512 aa77fc22d6c1c32e1361f0ccc42902f25cf18ac917f81428d32f1170b75ecb4fe73f639e8bb641822775326ec920f14308ad7f4c5c01cd8051305fccde9c5e9e
DIST foolscap-0.7.0.tar.gz 478999 BLAKE2B fbe3979efe8533a7727703af79aa3074f5ff54e4cd42cee4e981d8b2b73c445272792472236a52dc9fa69e9a25bd8cd30972d1fd2f37127db857ce5d5d3e7f6d SHA512 b2eb5415376d4e8e4ee3fd9ecef80a02d195d6b44059e5292c2daa7dcfdea9deafd8678ff89391128244a8d41fb6a69a92f9e4f07cc599f7358783dc8cb70f15
EBUILD foolscap-0.11.0.ebuild 1268 BLAKE2B 17697a21cb0a1914a37105fb74358777adb430301b08be1a64aea6e3386acc2c70146ce092604b8e2fe9f5f1f81ccf575b6b41891d4aa84c7cafe4648dc32801 SHA512 8f61c6d8e2f9d8dfb5992a639f2e1ffa4441686be755dd603979887b09d335578432c5aa589d5ab07019082d141be2c29fe688ca55f19bc226c1c7b380742620
+EBUILD foolscap-0.13.1.ebuild 1280 BLAKE2B baa2aebad2976eb72c1b172cfabfe836683d2b26ec5026075decf303fad0ac4d8aed978a5f1661464477e6795c93b22c6b855718717564d92d39ed0c9d727d11 SHA512 1103feefe4b6da74d3b7dbb5fdd2bf150e7bb80b73a6212476f50dca69b295e14c274de85ae82eac7160a530a20830331146d4d9a230673a84543af4d14efc1e
EBUILD foolscap-0.7.0.ebuild 910 BLAKE2B eda252d8f8aef4648d06e3c281fbae305669142dbaf1120482c97899b003721d37545e104c3c0b0c4e52e2da476b8e61fbb91e6609c555202144afa53d69cef8 SHA512 3c181ec3d826f9e1f8c843266e5513341530e4c62533f56107d600da7da08030747c9c1710913b2d66c0fe1441e2e2b418259108ec9d360f1301428d38c2501d
MISC metadata.xml 1272 BLAKE2B 2e8117819b9d14b123baeb54170b7e166c591af67d1d53911add7cf9cf1d7f5a1e23b00a4f32792d3109750a474c97341ae4d57db400c4884e2c212bfaea1547 SHA512 5509a54a69ca4d5c6898cdf125fc62d974b494dcce9117e9c66fc2e4e17b7f0d07e423739c9ea8b81cd2b3f16012400df9f764a5e2a4ab939edb2f8a3428ced0
diff --git a/dev-python/foolscap/foolscap-0.13.1.ebuild b/dev-python/foolscap/foolscap-0.13.1.ebuild
new file mode 100644
index 000000000000..39dfee6a6758
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.13.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac https://pypi.org/project/foolscap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc +ssl test"
+
+# Many tests still failing (#657604), others rely on network
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/twisted-16[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+#dev-python/txtorcon[${PYTHON_USEDEP}] will be needed when tests work
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_compile_all() {
+ local i;
+ if use doc; then
+ pushd doc > /dev/null
+ mkdir build || die
+ for i in ./*.rst
+ do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null
+ fi
+}
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/. )
+ distutils-r1_python_install_all
+}