summaryrefslogtreecommitdiff
path: root/dev-python/fritzconnection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /dev-python/fritzconnection
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest2
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.10.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 9b7f6e9b76c2..862b4c8e5bca 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1,3 +1,5 @@
+DIST fritzconnection-1.10.0.gh.tar.gz 146309 BLAKE2B 64b01a561a015fae10dc3aced2576afce5d27555aba019028de32d5dc0ee9099f4248d900ac1de0f18321d52537dd7b77ff010ce44ca863ef9b5c5e228c61071 SHA512 86acce864624f67fdbd407157565cec434d029907b4d295a3e5e1bb41d8856ca1eae99681fd3c44033c6bcef8ecc594483f734e08c4fb733e685c01147dd3c29
DIST fritzconnection-1.9.1.gh.tar.gz 79580 BLAKE2B 6972c92aabb9c516e2b4d3d18bea2daf8002a12c9939a5badd1ceb8f7539a243f99778a3ded0cd057850b54e9cb2a0ca9d2c31be688eaf81f4b279b74d10fc55 SHA512 55642cf1db581c62091d63fdfa9bf4fe36c545df686eae7d0f886b4ef8c186668e6f8fb7bc7786e13936764ea771e0dba79e62b57f19348dd562bf23a27d6369
+EBUILD fritzconnection-1.10.0.ebuild 720 BLAKE2B 8266d36789f99c3b87a6fc4961accfb41a0d7047100da007d7279b3f385d0be6b9f718865d6841b757fb10b3f6d6a6fc4d36a130e9e11e2374acabcfbd607028 SHA512 277ebc11c36d4d48aa5f59076725bc5fa3349aeb8ce5aaac37011b6d7b9826fc7025e759416642f47f632fb7024151d68e214d7b03eea63d1746d9a8c76ff99e
EBUILD fritzconnection-1.9.1.ebuild 720 BLAKE2B e99e847560c7bb83b7baab4d6c77bc5c8a454029df5a21edab8098fa7f5130515f6b68c84656981ceb8742d2ba12064fdc128d06169b4763bd76948bd5018e3f SHA512 45c8c729655481eac8b87cdec1a98c2b6f8ff5fcab1824abf74df3f563192112af4280d2872620a40011fb5920b262b88b11862eb2db272af6e03fe1a063300a
MISC metadata.xml 469 BLAKE2B f180fca33d0ab2fc81dc87fd39db87cf8c8ff51777062968a3ace592c9ac63af311273fda2db88c6772204ae24c21b4f195d1b7bacbb3c23f677dc7e8e309f1d SHA512 9ab24725dc0bb5b0e40ce79520d19c0348b08c7d779b53064111aa53fefefadc164b6140310df0a367d460d2fbb46345bdb2b7b6a9cf1beba3bbab1f7d7e2697
diff --git a/dev-python/fritzconnection/fritzconnection-1.10.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.10.0.ebuild
new file mode 100644
index 000000000000..c2a9b607584b
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="https://github.com/kbr/fritzconnection"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=dev-python/requests-2.22[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest