summaryrefslogtreecommitdiff
path: root/dev-python/frozenlist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
commit20e7188871e6d724b707132f925b9872536a91a0 (patch)
tree1b8d527714db0a937011ad650939d9152d36506c /dev-python/frozenlist
parente4769acf6646f4b0ef28cb695cec8ed128aba920 (diff)
gentoo auto-resync : 15:12:2023 - 20:53:45
Diffstat (limited to 'dev-python/frozenlist')
-rw-r--r--dev-python/frozenlist/Manifest2
-rw-r--r--dev-python/frozenlist/frozenlist-1.4.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
index e29b1b6dd08e..9b4dbf1188ec 100644
--- a/dev-python/frozenlist/Manifest
+++ b/dev-python/frozenlist/Manifest
@@ -1,5 +1,7 @@
DIST frozenlist-1.3.3.gh.tar.gz 27742 BLAKE2B cf0dcd2ed0e22cb7fa3d57a73177e53cace8e6301c462ab56544678f1f78f113ac3ad9ffb68dafb3ae957a1e52e2069dcec76b5adc27284587d614bbb6a8c139 SHA512 8f416996c18d352912e88dad6b503cb1e5ce566d69e97aad8d7eedc6415316e8c9e63eb2c341c5d2409ebf90fd58153ce642d5d88f277435bc6e5a4f1ce8b949
DIST frozenlist-1.4.0.gh.tar.gz 29063 BLAKE2B ec33639c22448da84fda9eaa83a78737f20579061e0ae05699a361ac9a8646df0ebf5c31df69cd7c4ee1c1c7fc0e28d0f6050a1879c3d28bf83e2caf442eb2a3 SHA512 937f7684df3879596903b5ce2d9a38590383a7c319e3079bbd8fdcbea169c692d9feabac0a7e0646d334ec517a86f7d943e0b0107fd925203de1cc8029b252ba
+DIST frozenlist-1.4.1.gh.tar.gz 46357 BLAKE2B 44ee864cd6c7918634d2db85937d778a8526f3117e4d27e06267c979bda2228de5bacaa87d8e0339f7718d6c12325336025214b8d42bdcc744aac7adb63b736a SHA512 a82059fd7d16ec8e17cdf9d05eb128194fc3eed7c20ea4a3daf508a949e6c039fb5824794eac1ca768de11d883f55f46de45f5dcc5031f5cb31291b33df87023
EBUILD frozenlist-1.3.3.ebuild 968 BLAKE2B ee09f69900d9fdaa304292d773222b2b0233c7230ccab7d0d37424ada2acc4ce50e56bc522a3ff51a08153a25efdd888f9f6e93d55017abffc91ddb9d0f9a601 SHA512 643832cb425d3b90b8d14b27c26cb5c60e80abdb30722b64273851ff4e03efdb89671bfc7ac037677ef5242cc1b42644a552ca6d8fadb6803f961297b09ad7ab
EBUILD frozenlist-1.4.0.ebuild 1216 BLAKE2B 13fef2819f4eac31532e56c45d5e53727f6147bcef32aaefd2df11ce7966ce432ab6a7b601cc7b68697ae5cc4207402e533e503b93bbad4b1947b556e6ad0100 SHA512 4dd5ccc90e339f948b6c70948fde06a0efb8bb8b0e4a4d3737897e9da39a6a1be2f99dc1dec523e92b6379f0da9654daf92ddf684ae66549f118046f97dc9de3
+EBUILD frozenlist-1.4.1.ebuild 1211 BLAKE2B b21a8e39a25b19d41beb66bb5bb07a5526b866663ccaf20c00d5c9ca777443741f719a9dda42d72484918efff7a0d1c119a59c057beb09190327d72ca613849c SHA512 382754c5f4bba4a5a123216b3c768764245909884cb9bc1e1c6c06e5f14f6e0bec341ac31cff26357199dedd2518c2867281ed74a6b43a2e1a6e568ca24dab2d
MISC metadata.xml 495 BLAKE2B 98916d3eb7834f06b99201a1339f8a432c2ce12aeb4038bba22ea218d73244151463d4671cdd18350c14ed8e466a93b31620f6f57fc306dcfeff9c812f8b71ec SHA512 0d0d154af4e43a5fde5fac025948a6c25e2b0efa2350b50e2a7cc826c576ced6c4746ba0a17d9d1cf0a304828d850acdef96e56381fae9728ef37fefc12b4ec5
diff --git a/dev-python/frozenlist/frozenlist-1.4.1.ebuild b/dev-python/frozenlist/frozenlist-1.4.1.ebuild
new file mode 100644
index 000000000000..149a004e224d
--- /dev/null
+++ b/dev-python/frozenlist/frozenlist-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
+HOMEPAGE="
+ https://pypi.org/project/frozenlist/
+ https://github.com/aio-libs/frozenlist/
+"
+SRC_URI="
+ https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # pypy is not using the C extension
+ if ! use native-extensions || [[ ${EPYTHON} != python* ]]; then
+ local -x FROZENLIST_NO_EXTENSIONS=1
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf frozenlist || die
+ epytest -o addopts=
+}