summaryrefslogtreecommitdiff
path: root/dev-python/frozenlist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-python/frozenlist
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-python/frozenlist')
-rw-r--r--dev-python/frozenlist/Manifest3
-rw-r--r--dev-python/frozenlist/frozenlist-1.2.0.ebuild39
-rw-r--r--dev-python/frozenlist/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
new file mode 100644
index 000000000000..9bc425fe5bd3
--- /dev/null
+++ b/dev-python/frozenlist/Manifest
@@ -0,0 +1,3 @@
+DIST frozenlist-1.2.0.gh.tar.gz 29062 BLAKE2B cc82db759906ad3e0be1806cacd6815377f264ed07ed272abb7da4753c11561564cf1cb4dfc0154abaeb4005f5607c26e602410a4ef45dd8e94e26583caa2ab7 SHA512 e5dda13e173db0b1c6e8c5a61949534f4eb30211cc4fcd102d0be1b55ee48e2db90d52fd770a2c6d6076f3a0d9e11289629a7a115c1270377636eda35d107e7a
+EBUILD frozenlist-1.2.0.ebuild 843 BLAKE2B 250e2841fe73f5aee55ed98ec64d679c77fc1e5c901a83c199d579eaaa63a99cdbddcf0b0fa6fcc8824c50933fb3b6b6fc75869a44c7060e1d098c52c7c52ac5 SHA512 eeb9b30e0eb987728dc94dc279698e2b38bcee73bf01630ce10963202e03e971d92d7702d7fff39df9b724d4c9cfac4988dcbe3a7d11c9bac36c5db8c8802d3c
+MISC metadata.xml 350 BLAKE2B a736540de62fb4fb95da57111cf8d08c3b64bb7ee8bd84cfbc0c4fe8bed3bb8c4e66215cf4ab93453af2efa73eb1676e68ebc01e24957abe7b209d1eb68e2800 SHA512 4fe629b8b52392065d096781396c5fc5c48d44b961a18d88741053dd99016268195317acb66c4fc2809058bb2d24b8c7cc760757254ccef7337b00a2387e3969
diff --git a/dev-python/frozenlist/frozenlist-1.2.0.ebuild b/dev-python/frozenlist/frozenlist-1.2.0.ebuild
new file mode 100644
index 000000000000..ba892fcc5c1d
--- /dev/null
+++ b/dev-python/frozenlist/frozenlist-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
+HOMEPAGE="
+ https://pypi.org/project/frozenlist/
+ https://github.com/aio-libs/frozenlist/"
+SRC_URI="
+ https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ # pypy is not using the C extension
+ if [[ ${EPYTHON} == python* ]]; then
+ > .install-cython || die
+ emake cythonize
+ fi
+}
diff --git a/dev-python/frozenlist/metadata.xml b/dev-python/frozenlist/metadata.xml
new file mode 100644
index 000000000000..c3f806ae6504
--- /dev/null
+++ b/dev-python/frozenlist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">frozenlist</remote-id>
+ <remote-id type="github">aio-libs/frozenlist</remote-id>
+ </upstream>
+</pkgmetadata>