summaryrefslogtreecommitdiff
path: root/dev-python/fsspec/fsspec-0.8.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/fsspec/fsspec-0.8.5.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/fsspec/fsspec-0.8.5.ebuild')
-rw-r--r--dev-python/fsspec/fsspec-0.8.5.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/fsspec/fsspec-0.8.5.ebuild b/dev-python/fsspec/fsspec-0.8.5.ebuild
deleted file mode 100644
index 50598ee6eb6c..000000000000
--- a/dev-python/fsspec/fsspec-0.8.5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="https://github.com/intake/filesystem_spec/
- https://pypi.org/project/fsspec/"
-SRC_URI="
- https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-BDEPEND="
- dev-python/versioneer[${PYTHON_USEDEP}]
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/fsspec-0.8.2-test-cleanup.patch
-)
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-python_test() {
- # sftp and smb require server started via docker
- pytest -vv \
- --ignore fsspec/implementations/tests/test_sftp.py \
- --ignore fsspec/implementations/tests/test_smb.py ||
- die "Tests failed with ${EPYTHON}"
-}