summaryrefslogtreecommitdiff
path: root/dev-python/funcparserlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/funcparserlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/funcparserlib')
-rw-r--r--dev-python/funcparserlib/Manifest3
-rw-r--r--dev-python/funcparserlib/funcparserlib-0.3.6.ebuild31
-rw-r--r--dev-python/funcparserlib/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/funcparserlib/Manifest b/dev-python/funcparserlib/Manifest
new file mode 100644
index 000000000000..c4f8c868f707
--- /dev/null
+++ b/dev-python/funcparserlib/Manifest
@@ -0,0 +1,3 @@
+DIST funcparserlib-0.3.6.tar.gz 30401 BLAKE2B cfce97cf08914f67ba3bd743bd3d6e7e7a03599ddc00d58a884aa84118d197d92bcc67a93ff1f7a2ab2074d66704078f5392c1d846004a5cd6eed2a423ba6b61 SHA512 efa52f788aa902b099660cb8bc60a025085a8c383e52bd0824a0c3ae28a6c13804a0659de0c80b4dcd839ee70491805d4eecda6cea221e35c3750ec569098c24
+EBUILD funcparserlib-0.3.6.ebuild 704 BLAKE2B 93d8674069801317bde28a436597121e2062240bde25fc488434c7f233c6847f0a0b047a7c7e61ee6b538779aab962d406ab72cc91e0c5975ad6d594d5a166ca SHA512 3152f4d263be2d2c9aac96ad327a96c75a6c2d031d38b079c7b86f76390957c2080fb4d44623afef8d6f3cb182441cfe0e06dce5e39c69b8609c969d3b62476d
+MISC metadata.xml 316 BLAKE2B 1899ee4255eb25643967fafb8aa09ea4b8e6319074de967e512d98ed182c2c7f7992c11c6689000f7bd2076b7296fc544fb8aff86fb03c86d661ce183a41c9b1 SHA512 9fe54328f405d097056ad5e3e0795ded4e3eacd72381dca3298a9af0e7c78f11eab97548b251c6bfaa9144dd0b00c00ac4292ad2ed5e84c31ab6c593a26b8caa
diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
new file mode 100644
index 000000000000..9f2bea939018
--- /dev/null
+++ b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://pypi.org/project/funcparserlib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local m=unittest
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( doc/*.md )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/funcparserlib/metadata.xml b/dev-python/funcparserlib/metadata.xml
new file mode 100644
index 000000000000..48fa62ab4ac6
--- /dev/null
+++ b/dev-python/funcparserlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">funcparserlib</remote-id>
+ </upstream>
+</pkgmetadata>