summaryrefslogtreecommitdiff
path: root/dev-python/funcsigs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/funcsigs
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/funcsigs')
-rw-r--r--dev-python/funcsigs/Manifest4
-rw-r--r--dev-python/funcsigs/files/funcsigs-1.0.2-fix-pypy3-tests.patch94
-rw-r--r--dev-python/funcsigs/funcsigs-1.0.2-r2.ebuild33
-rw-r--r--dev-python/funcsigs/metadata.xml11
4 files changed, 0 insertions, 142 deletions
diff --git a/dev-python/funcsigs/Manifest b/dev-python/funcsigs/Manifest
deleted file mode 100644
index 1498805e4742..000000000000
--- a/dev-python/funcsigs/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX funcsigs-1.0.2-fix-pypy3-tests.patch 3154 BLAKE2B face7accdd8bc2c5d3ab9dbcf9fa172695901768849d9278b0b384819b4c6ca3409f8dba3d9ce058f16e88f0696d1fd7dd6d3b7ba119989fb8b3e97fa0399635 SHA512 f4f93b2587fe2b0a41dda070d827f663785c367fcb3a181c0f461175ebeff47147907cc901954cb98cb7cce25754535663fbefe9227462fa2963d3ed572a852a
-DIST funcsigs-1.0.2.tar.gz 27947 BLAKE2B 3006d46018ae040b930e397c3f11575ae0ef18a8b2c9b6c10075804d83d23bea1fb81179de85180146673e0bd4c775a68c0ff624cdaceb1894efe5b2c8fd753c SHA512 4e583bb7081bb1d6c0fe5a6935ca03032d562b93ef5c11b51a72ce9e7ac12902451cc2233c7e6f70440629d88d8e6e9625965ee408100b80b0024f3a6204afda
-EBUILD funcsigs-1.0.2-r2.ebuild 947 BLAKE2B 0075a72270bc94a362384ced4411b9cce64b48ac6b3cd2953591a94357f017f11d5ed7ed09017a9170efa339e58da6f80185b86850331d55248457d6d5d301da SHA512 48bd5fc1d90c5733b69ecec148a940686c6e975ff5f59b76239d6f210e7a3c68f383fcff04f94f7638042602af00c76ae60907f155ac87c54aed976078668da0
-MISC metadata.xml 321 BLAKE2B 8aa6245455756e5d3a197dfb37bb706551ff8ea0c6beb047d0c59c54d2ed74853e6d9857d37a531a5313a7a85a0849f5e0b308a58fa98a3cce6040b5b91a1a80 SHA512 a3df23a85e33881f6ac0da0b0e33fd69de760c79e636574982606964134d303bfa219f429006a54ad71622c05c07b6eb233a1e8918f4703257b0e8c389acb6d8
diff --git a/dev-python/funcsigs/files/funcsigs-1.0.2-fix-pypy3-tests.patch b/dev-python/funcsigs/files/funcsigs-1.0.2-fix-pypy3-tests.patch
deleted file mode 100644
index f4ecec3b6137..000000000000
--- a/dev-python/funcsigs/files/funcsigs-1.0.2-fix-pypy3-tests.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-diff --git a/tests/test_inspect.py b/tests/test_inspect.py
-index 98d6592..3a2a1f2 100644
---- a/tests/test_inspect.py
-+++ b/tests/test_inspect.py
-@@ -8,6 +8,7 @@ import unittest2 as unittest
-
- import funcsigs as inspect
-
-+import platform
-
- class TestSignatureObject(unittest.TestCase):
- @staticmethod
-@@ -409,7 +410,7 @@ def test_signature_on_decorated(self):
- Ellipsis))
- """)
-
-- if sys.version_info[0] > 2:
-+ if sys.version_info[0] > 2 and platform.python_implementation() != "PyPy":
- exec("""
- def test_signature_on_class(self):
- class C:
-@@ -493,41 +494,44 @@ def test_signature_on_class(self):
- Ellipsis))
- """)
-
-- def test_signature_on_callable_objects(self):
-- class Foo(object):
-- def __call__(self, a):
-- pass
-+ if platform.python_implementation() != "PyPy":
-+ exec("""
-+def test_signature_on_callable_objects(self):
-+ class Foo(object):
-+ def __call__(self, a):
-+ pass
-
-- self.assertEqual(self.signature(Foo()),
-- ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-- Ellipsis))
-+ self.assertEqual(self.signature(Foo()),
-+ ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-+ Ellipsis))
-
-- class Spam(object):
-- pass
-- with self.assertRaisesRegex(TypeError, "is not a callable object"):
-- inspect.signature(Spam())
-+ class Spam(object):
-+ pass
-+ with self.assertRaisesRegex(TypeError, "is not a callable object"):
-+ inspect.signature(Spam())
-
-- class Bar(Spam, Foo):
-- pass
-+ class Bar(Spam, Foo):
-+ pass
-
-- self.assertEqual(self.signature(Bar()),
-- ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-- Ellipsis))
-+ self.assertEqual(self.signature(Bar()),
-+ ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-+ Ellipsis))
-
-- class ToFail(object):
-- __call__ = type
-- with self.assertRaisesRegex(ValueError, "not supported by signature"):
-- inspect.signature(ToFail())
-+ class ToFail(object):
-+ __call__ = type
-+ with self.assertRaisesRegex(ValueError, "not supported by signature"):
-+ inspect.signature(ToFail())
-
-- if sys.version_info[0] < 3:
-- return
-+ if sys.version_info[0] < 3:
-+ return
-
-- class Wrapped(object):
-- pass
-- Wrapped.__wrapped__ = lambda a: None
-- self.assertEqual(self.signature(Wrapped),
-- ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-- Ellipsis))
-+ class Wrapped(object):
-+ pass
-+ Wrapped.__wrapped__ = lambda a: None
-+ self.assertEqual(self.signature(Wrapped),
-+ ((('a', Ellipsis, Ellipsis, "positional_or_keyword"),),
-+ Ellipsis))
-+""")
-
- def test_signature_on_lambdas(self):
- self.assertEqual(self.signature((lambda a=10: a)),
diff --git a/dev-python/funcsigs/funcsigs-1.0.2-r2.ebuild b/dev-python/funcsigs/funcsigs-1.0.2-r2.ebuild
deleted file mode 100644
index 0a8b618ac413..000000000000
--- a/dev-python/funcsigs/funcsigs-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python function signatures backport from PEP362 for Python 2.7-3.5"
-HOMEPAGE="https://pypi.org/project/funcsigs/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- # This patch disables some tests for pypy as they do not work as expected.
- # This has been reported upstream
- # https://github.com/testing-cabal/funcsigs/issues/10
- "${FILESDIR}/${P}-fix-pypy3-tests.patch"
-)
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/funcsigs/metadata.xml b/dev-python/funcsigs/metadata.xml
deleted file mode 100644
index bb74f00502a5..000000000000
--- a/dev-python/funcsigs/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">funcsigs</remote-id>
- </upstream>
-</pkgmetadata>