summaryrefslogtreecommitdiff
path: root/dev-python/fusepy/fusepy-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/fusepy/fusepy-3.0.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/fusepy/fusepy-3.0.1.ebuild')
-rw-r--r--dev-python/fusepy/fusepy-3.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/fusepy/fusepy-3.0.1.ebuild b/dev-python/fusepy/fusepy-3.0.1.ebuild
new file mode 100644
index 000000000000..dff543e781d4
--- /dev/null
+++ b/dev-python/fusepy/fusepy-3.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings using ctypes"
+HOMEPAGE="https://github.com/fusepy/fusepy https://pypi.org/project/fusepy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=sys-fs/fuse-2.9.7:0
+ !dev-python/fuse-python
+"