summaryrefslogtreecommitdiff
path: root/dev-python/fusil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/fusil
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/fusil')
-rw-r--r--dev-python/fusil/Manifest4
-rw-r--r--dev-python/fusil/fusil-1.5-r1.ebuild35
-rw-r--r--dev-python/fusil/fusil-1.5.ebuild36
-rw-r--r--dev-python/fusil/metadata.xml12
4 files changed, 0 insertions, 87 deletions
diff --git a/dev-python/fusil/Manifest b/dev-python/fusil/Manifest
deleted file mode 100644
index b064ba0fb9de..000000000000
--- a/dev-python/fusil/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST fusil-1.5.tar.gz 138910 BLAKE2B b3f1d07e40116aadfd3aa008366f9598015e741bd5caa364050e26d6a8d9d9c4fe8bb021431737f58ea54bbfb79808fa1ae99568afadad3ae509937910578f90 SHA512 0d84bfd2d9b8e509989723de26b30c3ec2824612dbdcc097ff3e998fd4efa6b1293cb78743e098ad5012d4981b8e8036f3ad3f9c6acf2dc30e3ff1f707c7d1c0
-EBUILD fusil-1.5-r1.ebuild 850 BLAKE2B 2d367af89aeb7c8cb247a391f2ca1ddce76532e7f309cafd1b4e62d308b9d8304b546a62a6dc5d9843ff6422bd66475edb7824aa968f7923c8ad7091459e7b52 SHA512 03a5a1accb1000924e72363488945e67b418cb94c37df52d81ad8c07b5051ac9045efbaa23f437e45057174b48954012b14c160de2f5897d9c65a9ad89e2173d
-EBUILD fusil-1.5.ebuild 938 BLAKE2B 722e16983849025973421510668a700ad92e75f929ea7a8158c31d3e9a0d084f920a25d605e32904135b79a452a5c76ba8c7fadf23ddd06b8c21a8fd649b161f SHA512 64de057453435a35afcfb71b23bf4d4e9a2f53ec77d045e498e121bbd855344e18b8a5bf6ae030f288f8b6f1afe840cd8520bce48ecf1cb8e628dad7282bc128
-MISC metadata.xml 374 BLAKE2B 7580e8059db1c7decc3688c34c4da02af104576b257904129929e9619cd94384a10db1514dbd64b638b3e2b44e19b9e051af0bc325c1505628cda806d8f5e213 SHA512 98947683cbc807385f692511afa4402ed11644fbece4ecad9888cb8beb90d4154f9ddad104210ab2e7fc0641cadb654a826786a57ffb6fbae158eb3aefe0bdba
diff --git a/dev-python/fusil/fusil-1.5-r1.ebuild b/dev-python/fusil/fusil-1.5-r1.ebuild
deleted file mode 100644
index e7a28cd94155..000000000000
--- a/dev-python/fusil/fusil-1.5-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1 user
-
-DESCRIPTION="Python library to write fuzzing programs"
-HOMEPAGE="https://bitbucket.org/haypo/fusil/wiki/Home https://pypi.org/project/fusil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/python-ptrace-0.7[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && emake -C doc RST2HTML="rst2html.py"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- enewgroup "${PN}"
- enewuser "${PN}" -1 -1 -1 "${PN}"
-}
diff --git a/dev-python/fusil/fusil-1.5.ebuild b/dev-python/fusil/fusil-1.5.ebuild
deleted file mode 100644
index 4a13a9f1b432..000000000000
--- a/dev-python/fusil/fusil-1.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1 user
-
-DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing programs"
-HOMEPAGE="https://bitbucket.org/haypo/fusil/wiki/Home https://pypi.org/project/fusil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/python-ptrace-0.7[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- if use doc; then
- emake -C doc RST2HTML="rst2html.py" || die "Generation of documentation failed"
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- enewgroup fusil
- enewuser fusil -1 -1 -1 "fusil"
-}
diff --git a/dev-python/fusil/metadata.xml b/dev-python/fusil/metadata.xml
deleted file mode 100644
index 030b6dace8fe..000000000000
--- a/dev-python/fusil/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">fusil</remote-id>
- <remote-id type="bitbucket">haypo/fusil</remote-id>
- </upstream>
-</pkgmetadata>