summaryrefslogtreecommitdiff
path: root/dev-python/futures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/futures
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/futures')
-rw-r--r--dev-python/futures/Manifest5
-rw-r--r--dev-python/futures/futures-3.1.1.ebuild35
-rw-r--r--dev-python/futures/futures-3.2.0.ebuild34
-rw-r--r--dev-python/futures/metadata.xml12
4 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/futures/Manifest b/dev-python/futures/Manifest
deleted file mode 100644
index 75d90ee928d7..000000000000
--- a/dev-python/futures/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST futures-3.1.1.tar.gz 26471 BLAKE2B 53c7678cec213351bc1c172de857c60bbcc392f24a0a6d1fba42eb6190f82d8f01977f8b830e9db5ba0628eb50f2d6dcf0d0421c4b06e42adbd1d429c0c28281 SHA512 7ccb041271ed2688591942f46ab2d2c92d806efbd5209ff9aba77c6d5d3c1a1495fccbeb1718d914894b0b8d936438687e8f3cc22b7ab6625fb518321084ead3
-DIST futures-3.2.0.tar.gz 27320 BLAKE2B b2a6c380955ce29fd434e30897d39d1fe1dbe758ec663bb243c4891849f3e45cf5eba10b71a9e6a028b32f20f876d5662188ec387d442492c7f4b73463b2f728 SHA512 e8c08ebc38d7397b5c2a5dc8c22567af1a1b6d5ce6fb8c189f663fb25b96f1ebcbade1ec0a95e9970dfac73606ecd5d7c6f79cc010fd62930a5b005d9babdde0
-EBUILD futures-3.1.1.ebuild 850 BLAKE2B 68bf47e27209822e72e0fd863cb93cc984c4e069ce19dbc42cd79c648aa46d1e7178925088f274f41e4c038a3f4019b660d2f9fa6b2e90f6f4bdb3ccf35f9be4 SHA512 bca3fe4b67f520223aeb10b0fac319383e0b835272e4141bd9fccdcdc3f24bac6e8f5eeb349bc782342c55341b0bd7abba48bdaf83c97836595690cd25812891
-EBUILD futures-3.2.0.ebuild 879 BLAKE2B 35556679925ad819460527aaef7a4a4c480d0adabb894e066d7eaab4e23c0f85ae429885d6ead1f010fb9323b6a537b99003c9c56291f4d4241546e26b6bada6 SHA512 deef4b0088a8e0696b53fe5070c1c08676bfe1f952192e819653359ec28aa30b4360e587cba235ea00a4f1800519d864f487fd58943cbdc0273a18acd226eebd
-MISC metadata.xml 373 BLAKE2B 1e9903ae68ebe8e33d96f6e6f811fe125edb4f81b1c84c21fa9f962ce4fe7053269d00f29ef5699fcab98e70a755414ad86db30afc528be60ded71e6f60f9eea SHA512 df8ba320e5dfd914b6cc6cb15dbd5efc19047c0d57c44a60fd401de9a7f9c59e06b5975dd832c78202aa34fad94e0771e8a5ff6f16f246c220c5640ec2c84921
diff --git a/dev-python/futures/futures-3.1.1.ebuild b/dev-python/futures/futures-3.1.1.ebuild
deleted file mode 100644
index 1e3c384b14fc..000000000000
--- a/dev-python/futures/futures-3.1.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
-HOMEPAGE="https://pypi.org/project/futures/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES )
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/futures/futures-3.2.0.ebuild b/dev-python/futures/futures-3.2.0.ebuild
deleted file mode 100644
index 5cacc0a02f22..000000000000
--- a/dev-python/futures/futures-3.2.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
-HOMEPAGE="https://github.com/agronholm/pythonfutures https://pypi.org/project/futures/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/futures/metadata.xml b/dev-python/futures/metadata.xml
deleted file mode 100644
index 97247087804f..000000000000
--- a/dev-python/futures/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="github">agronholm/pythonfutures</remote-id>
- <remote-id type="pypi">futures</remote-id>
- </upstream>
-</pkgmetadata>