summaryrefslogtreecommitdiff
path: root/dev-python/futurist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/futurist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/futurist')
-rw-r--r--dev-python/futurist/Manifest5
-rw-r--r--dev-python/futurist/futurist-1.3.1.ebuild30
-rw-r--r--dev-python/futurist/futurist-1.6.0.ebuild29
-rw-r--r--dev-python/futurist/metadata.xml11
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/futurist/Manifest b/dev-python/futurist/Manifest
new file mode 100644
index 000000000000..4d1bbf2834ed
--- /dev/null
+++ b/dev-python/futurist/Manifest
@@ -0,0 +1,5 @@
+DIST futurist-1.3.1.tar.gz 40927 BLAKE2B 7a746bc7dbdfe1ac9ff2fcdd02a0f4f6e0caccadb52b46439620bc5daf736545de906d0a8d159d39fe7d0ab8eda05767aff4723607dc777ec5c1b43a1670c277 SHA512 88b3af8922542d0bcc3e3e1ba8c456adb6233a616c1e14b3b49b11162be5b65855e7088ae6ce573d42bc80675f51070270533fea65e70935304954a3889db3e3
+DIST futurist-1.6.0.tar.gz 40372 BLAKE2B 295a2a274de8a613025c6c46f6abd048cc6d988e9f4c5dc2de9559d295d88f2d93e5afc017dbd8c9c20a6bb50a63567d42f3ac46c61fd9b0d08a028dbdb2c5bf SHA512 fdbd93e3ffa61661218e4a3f180a448b1d8c75126847c50a36264543bac02f50984d4e493031c0ce3257d16661f7b4a4463b5b3dfd7ae7e2f974410e0d1234a1
+EBUILD futurist-1.3.1.ebuild 908 BLAKE2B 075b5587f206622f643ff9bfb325b9c86433895ed6f1726ade2c9c7afb271755588021bb873c3eaf74749d09e4edcbbfa94e9859eeff7520546a1cedab47088c SHA512 082a21f70e1789695e629d1fafade7ae370f6a075329e6c2fb6a3cfd626f4f757a6c5d69245150e5193e26947d77f73f39d60593c8bf047c20c3b2bf4da4c01c
+EBUILD futurist-1.6.0.ebuild 862 BLAKE2B 1493365757318eb2d045c0b59ba9876b819d7731fcadbf3d7b66edf9a2c6d430c1586d35bf1561537e1717c37dea0715a3f2c8f2fb6e7fb7d2d780ab22f6133e SHA512 b2a2e21763aae9b532ee94de6a196456de9cdb1e92a612f2cd2acac529add75be7b30302c1b3defa11424b57b749ecd9e7580729f8756740a75e2ff920d868fc
+MISC metadata.xml 325 BLAKE2B fd30488beae3d9648ca9812b6b719c85c4b8aa98bd1209400fcfbc729955ffd8d3690a145b26fe5404737d2b2df346a73547abf3b519e0f8d6200686a4bcb62f SHA512 4d4d42c2821349f1a2144c297cf80c572482eff31cd1fb4f43f43c503d1533a1ea53627528cfac417ab0d1c174f7924f951f823c9577ebea86ce7cdd88195bed
diff --git a/dev-python/futurist/futurist-1.3.1.ebuild b/dev-python/futurist/futurist-1.3.1.ebuild
new file mode 100644
index 000000000000..d2d394d46820
--- /dev/null
+++ b/dev-python/futurist/futurist-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.org/project/futurist/ http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/futurist-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]"
diff --git a/dev-python/futurist/futurist-1.6.0.ebuild b/dev-python/futurist/futurist-1.6.0.ebuild
new file mode 100644
index 000000000000..646a426bd78a
--- /dev/null
+++ b/dev-python/futurist/futurist-1.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.org/project/futurist/ http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]"
diff --git a/dev-python/futurist/metadata.xml b/dev-python/futurist/metadata.xml
new file mode 100644
index 000000000000..c2513943d020
--- /dev/null
+++ b/dev-python/futurist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">futurist</remote-id>
+ </upstream>
+</pkgmetadata>