summaryrefslogtreecommitdiff
path: root/dev-python/gast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-python/gast
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-python/gast')
-rw-r--r--dev-python/gast/Manifest2
-rw-r--r--dev-python/gast/gast-0.5.5.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/gast/Manifest b/dev-python/gast/Manifest
index f651c25fddfb..932da21dfc9d 100644
--- a/dev-python/gast/Manifest
+++ b/dev-python/gast/Manifest
@@ -1,3 +1,5 @@
DIST gast-0.5.4.tar.gz 25346 BLAKE2B c7161737367c2a3335d9e51af1dc09934ea16694d497cb151ed713b3372666456b5dcc2c595294c7162035af29d454bad5c8fb677030de9235c52d5ff8a3f05b SHA512 a288e2ecc15af2a5d50cb34979995f936e88cdaa4427f809b69015cb6ba98eaffd7ea9eff2dc61dae6f6c2d7d9c5cc6e3e9a5565bd7b1dd308cd39f56087c67d
+DIST gast-0.5.5.tar.gz 26733 BLAKE2B bc309969ace97920b7278fb329ecaa050090df3b9624d70350ce16bb090dbb0f4474407c34457abc2d1b8e728671c0e886ec46b2c94237b678575be34d593e98 SHA512 7325c9096f99f43e2d791f39acd7e655724e23c9cd93a838ae703377eedd23190af0f52ae07330323b90ef95bdcf6d032d39030823749557fecd9d00321a4163
EBUILD gast-0.5.4.ebuild 507 BLAKE2B 4137fc77c6b9ab0637d300f635ac5617361150b36493c133c4664abf4d8e6218d61b7aadf027d95663aa21e83352e263e4e73e8bc421a973e1635ff2d0323bd3 SHA512 ed267bcec64c63d117461af01a7b63f7658b5e6459588b623c8caaf394d22176085e3b6873b14ba7468e1ec743919e2ab57e54772ffe08a0f6bdb537cb78fe84
+EBUILD gast-0.5.5.ebuild 560 BLAKE2B 4eb4e8f641093570d17a630a0edb5e1ffb5b4e2a72bf17eb3dc488718dc632954e7589729e9cf813e40e90a00e38e5f3c5be412c79508a2575bfa18e1acb3d51 SHA512 5c1f3e068063666a8717b79983e440e8a2e2def7ac26951e640c2967c455841940edd9c3d971cefaf7f8e3b122e11554706b37f71d16184c39ddd0a5a0bf9f1e
MISC metadata.xml 739 BLAKE2B 6a226f9d712552a98ff4e7562da4097bb307fc7641085f45aed3f8610fefcb01e8458e96a5e46af30e3e01574415149269dcf5222229290225dd5f02543959b0 SHA512 02f9b1a30219372f6b769158ff9fb096a74f7d8ee6b67f5f9ad23ff382ce450767867a4074e04b1d5ac77e1987c3e9b661630e7626b68f8b5270032d7684161d
diff --git a/dev-python/gast/gast-0.5.5.ebuild b/dev-python/gast/gast-0.5.5.ebuild
new file mode 100644
index 000000000000..4747a4e751f1
--- /dev/null
+++ b/dev-python/gast/gast-0.5.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="
+ https://github.com/serge-sans-paille/gast/
+ https://pypi.org/project/gast/
+"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_tests unittest