summaryrefslogtreecommitdiff
path: root/dev-python/gcs-oauth2-boto-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-python/gcs-oauth2-boto-plugin
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest1
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index 2cccd30d3d59..c06ba53c332d 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -6,5 +6,6 @@ DIST gcs-oauth2-boto-plugin-1.8.tar.gz 13248 BLAKE2B 831a1b88035d6331ac2cb122fda
DIST gcs-oauth2-boto-plugin-2.1.tar.gz 15789 BLAKE2B f98eb41d07aede9379bb256723c217be1c2fcf2cda18e555a5d7e85bb402215052ff4d7770cdb4066fd989f7e78d070ea19e1a469f5e6dec2b94a367a6dc3c19 SHA512 26b519fa2987e83a687907aa72e0c9eb8b2a2c48143bc1bf13bad79791379daaae190a23f9f35d1a570e21c6800d5860bbb94f3c3f3b2ff7bfcfec8a5a39af7c
EBUILD gcs-oauth2-boto-plugin-1.14.ebuild 1439 BLAKE2B 66828bc28dde34353e74778bd8cfae10cf05b14b209b331c5cd722158b1890ff278e1ce5f6daae4d43242a2ae07214549ecd5158123957cc6344e377b51ad903 SHA512 94c821a1f3812ae3f3d4af4092a687630ce5ee660e12e9afec2642be081d4e1b54a6e064461d391dff9a04ae0f0531626fec507b0c86e62e372657d4dbcbc07a
EBUILD gcs-oauth2-boto-plugin-1.8-r1.ebuild 1039 BLAKE2B 861b5581f1522c8e648b1c081843071f30bc066a53d26e6826494760258a3dbafb71500ba9bc45267ca026b1e5b519ee4b17105a96b2f48a81287aabd6abd3eb SHA512 4026ecf2f8380a7371cd87dded9837632a5711cd098d4d2bfc214308c2ad687e8c0e452f120029fddbf3fd47085b9d65aca011a22d79ed520d4f0ca52eebd6cf
+EBUILD gcs-oauth2-boto-plugin-2.1-r1.ebuild 1406 BLAKE2B d793da60d2835973b52f7ca0cb86b3eb79956f576000087f46c63f2ce0cfa8a515afead51a933a9f6a0ac95e87cfb5d11247afe72ccc52c6ec1c5f01ea47f4ea SHA512 b01b31022673ebd630aff831fc9dcabf1fc9fac09f3c00dcde46bf6ea644892f36e72e234724548955fd417c33c887b6f48ebeb13f9d6ae45dd102be418af7bd
EBUILD gcs-oauth2-boto-plugin-2.1.ebuild 1351 BLAKE2B 391603e2e4847094eb8d39eadf43a64d87bb2b437a4cf584a5ca4349f678b26aac89aa7aaf9d47ce16c47484ecc1014b23d6baf7ed1050a5f5cfdb0e67ff4f52 SHA512 f416fb12fc52f976f850aa4b4e8d18e9a639808ed8fd7b3639c0696899633d9169660c533b3bbcfd0a4b050748a50364e013916bdf21b6e56bce194f56f77d81
MISC metadata.xml 335 BLAKE2B 11f766d7bfb5e7ddb78ea1d749d3d2d79496d69e07b1054bede831ba7824d8705e064e5842c71206a0c35cea37e40558a6cdafd8ebf8460ee99ff8dce3f26ac5 SHA512 cb494f35eba6442585175997cb16c7d4f6eea841e56f2828386f0894e68a7d917c010264bea46d7b6ae1957633763c66a5b669606fd8b0fcba3b4555fa926807
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild
new file mode 100644
index 000000000000..38df5638f09d
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
+HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
+)
+
+# Keep versions in sync with setup.py.
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
+ dev-python/google-reauth-python[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+ !=dev-python/oauth2client-2.0*
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e '/SocksiPy-branch/d' \
+ setup.py || die
+ # Make sure the unittests aren't installed.
+ mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
+}
+
+python_test() {
+ ${EPYTHON} "${S}"/test_oauth2_client.py || die
+}